[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No valid bibliography in this document

From: Arash Esbati
Subject: Re: No valid bibliography in this document
Date: Thu, 19 Mar 2020 22:55:54 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50

Hi Jobst,

"Hoffmann, Jobst" <address@hidden> writes:

>> Me either.  The only difference I currently see are the entries in our
>> .emacs files.  For RefTeX, I only have these lines:
>>     (require 'reftex)
>>     (add-hook 'LaTeX-mode-hook #'turn-on-reftex)
>>     (setq reftex-plug-into-AUCTeX t)
> I've reduced my settings to these three lines, no change.
>> Maybe you adjust your setting as well, restart Emacs and try it again.
>> Did you try my other suggestion to select
>>     Ref->Parse Document->Entire Document
>> from the menu?
> Yes, I did it yesterday, it didn't help; now at this moment I did it
> again and it works!?????????
> I'm curious about tomorrow...

How was your day today? ;-)

> Emacs 26.3 from Fedora, all updates - if any - applied, several packages
> from melpa and of my own.

One thing you could try is to start Emacs with `emacs -Q' and then eval
the AUCTeX and RefTeX relevant parts for your .emacs file in *scratch*
before loading your .tex file, maybe that helps.

> Now I tried another example, a step to multi file projects. I applied
> all the tricks, but the message was always:-(
> "\\bibliography statement missing or .bib files not found"
> I attach the example - the bibliographic file comes with biblatex, so I
> assume that you have your own copy, it is in the BIBINPUTS serach path
> and it works in another example, I've also linked it into the current
> directory -, how is it working for you?

I tried it with the files attached without a problem.  One thing I found
out is a bug in a regexp in `latex.el':

    (defvar LaTeX-auto-minimal-regexp-list
         (3 5 1) LaTeX-auto-style)
         (3 4 1) LaTeX-auto-style))
      "Minimal list of regular expressions matching LaTeX macro definitions.")

The regexp seems broken to me as fails to parse due to a \ in \refsectionmode:


My suggestion to other developers: Make the following change:

-       ("\\\\use\\(package\\)\\(\\[\\([^\]\\]*\\)\\]\\)?\
#       ("\\\\use\\(package\\)\\(\\[\\([^]]*\\)\\]\\)?\

But this doesn't make a difference for RefTeX.

Best, Arash

Attachment: lecure_multi.tex
Description: TeX document

Attachment: chapter_one.tex
Description: TeX document

Attachment: chapter_two.tex
Description: TeX document

Attachment: chapter_three.tex
Description: TeX document

Best, Arash

reply via email to

[Prev in Thread] Current Thread [Next in Thread]