[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [feature/native-comp] breakage on build

From: phillip . lord
Subject: Re: [feature/native-comp] breakage on build
Date: Sat, 30 Jan 2021 14:40:32 +0000
User-agent: Roundcube Webmail/1.4.10

On 2021-01-30 13:26, akrl--- via "Emacs development discussions." wrote:
Phillip Lord <phillip.lord@russet.org.uk> writes:

I am getting a build breakage on native-comp. While I can build
native-comp on windows in source, it seems to fail while using my
packaging scripts. These use out-of-source builds which might be the

Backtrace is here. I've added a few "message"'s to
`comp-compile-ctxt-to-file' so I could see the full paths. The directory
mentioned does exist but is empty.

I am getting that there is something that isn't happy with windows
paths, but that's a total guess.


Hi Phil,

I tried just now an out of tree build on x86_64-pc-linux-gnu and it
worked.  This might confirm your idea of a Windows specific issue?

Would be interesting to debug and see exactly what's the file that we
can't create and why.

I will give it a go and see what I can find. I'd checked an OOS build on linux already, but I don't think I have done a "normal" one, that is not using my packaging scripts, on windows. Will try.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]