[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem building latest git source

From: Robert Goulding
Subject: Re: Problem building latest git source
Date: Thu, 7 Jul 2022 07:52:11 -0400

And I checked out a brand new clone of the repository, and build failed
with the same error about Ghostscript 9.27.

On Thu, Jul 7, 2022 at 7:20 AM Robert Goulding <>

> I can't understand it myself, but I did "make distclean" and
> re-configured, and got precisely the same error about 9.27. Twice  Even
> though my configure output matches yours, and identified my Ghostscript as
> 9.53, and said that URW fonts were found. I'll try deleting and
> redownloading and rebootstrapping my copy, in case there is something stuck
> in there. Robert
> Robert Goulding
> Sent from my phone
> On Thu, Jul 7, 2022, 12:48 AM G. Branden Robinson <
>> wrote:
>> [looping in groff@gnu]
>> Hi Robert,
>> At 2022-07-06T17:34:49-0400, Robert Goulding wrote:
>> > I checked out the latest source and tried building it on my Chromebook
>> > (i.e., Debian 11 (bullseye)). The compile stopped when it tried to
>> > build the pdf of all the man pages:
>> >
>> > make[1]: Entering directory '/home/rdgoulding/groff-git'
>> >   GROFF    doc/groff-man-pages.pdf
>> > gropdf:src/utils/addftinfo/addftinfo.1: fatal error: failed to open
>> > '/usr/share/ghostscript/9.27/Resource/Font/NimbusRoman-Italic'
>> > make[1]: *** [Makefile:12695: doc/groff-man-pages.pdf] Error 1
>> > make[1]: *** Deleting file 'doc/groff-man-pages.pdf'
>> > make[1]: Leaving directory '/home/rdgoulding/groff-git'
>> > make: *** [Makefile:5701: all] Error 2
>> >
>> > The odd thing is that I have ghostscript version 9.53.3 installed, not
>> > 9.27, and the font it can't find is at
>> > /usr/share/ghostscript/9.53.3/Resource/Font/NimbusRoman-Italic
>> I hadn't built in my bullseye chroot lately because I stopped fiddling
>> with the build system for a while (apart from adding regression tests),
>> but I too have a problem, though it differs from yours.
>> In my chroot, the BuildFoundries script is not locating the 'afmtodit'
>> command (which is one of the build artifacts).  This happens with both
>> in-tree and out-of-tree builds.  My bullseye chroot also uses
>> Ghostscript 9.53.3, and these fonts _are_ found.  Please find part of my
>> 'configure' output below.
>> Nothing in the build hard-codes the Ghostscript version number used in
>> the font search path, so I am wondering if you haven't forgotten to
>> re-run 'configure'.  It might help to 'make distclean' first...but I
>> wouldn't be surprised if you hit the same afmtodit problem I did.  I'll
>> look at BuildFoundries and see if I can spot an error, but Deri's eyes
>> will be better than mine here.
>> In the below, you might want to see how your 'configure' output compares
>> to mine for the "gs version" and "URW fonts" checks.
>> Deri, can you throw any light on this stuff?
>> Regards,
>> Branden
>> checking for gs version with good left sidebearing handling... got 9.53.3
>> (buggy)
>> checking whether we are using the GNU C Library >= 2.1 or uClibc...
>> (cached) yes
>> checking for URW fonts in Type 1/PFB format... found in
>> /usr/share/fonts/type1/urw-base35/
>> checking that generated files are newer than configure... done
>> configure: creating ./config.status
>> config.status: creating Makefile
>> config.status: creating test-groff
>> config.status: creating src/include/config.h
>> config.status: executing depfiles commands
>> GNU roff version 1.23.0.rc1.2692-2d9e
>> ----------------------------------------------------------------------
>>  installation directory prefix    : /usr/local
>>  C++ compiler and options         : g++ -g -O2
>>  use libgroff's memory allocator  : no
>>  C compiler and options           : gcc -g -O2
>>  Perl interpreter version         : 5.32.1
>>  X11 support                      : disabled
>>  'groff -l' uses print spooler    : no
>>  use URW fonts for PDF output     : yes
>>  preconv can use uchardet library : no
>>  can build groff.dvi, groff.pdf   : no
>>  tests can use poppler PDF tools  : no
>> ----------------------------------------------------------------------
>> configure: The uchardet library was not found.
>>   The 'preconv' preprocessor program will be unable to attempt automatic
>>   inference of an input file's character encoding.  See the preconv(1)
>>   man page.
>> configure: Buggy version of Ghostscript detected.
>>   Ghostscript versions 9.00 <= x < 9.54 suffer from a rendering glitch
>>   that affects the AT&T troff (and groff) special character '\(lh'; see
>>   <>.  If your
>>   version of Ghostscript has not been patched to fix this problem, you
>>   may need to work around it in groff documents you render for the
>>   PostScript (and, for tbl(1) tables, HTML) output devices.
>> configure: The program 'psselect' was not found in $PATH.
>>   Consequently, groff's HTML output driver, 'grohtml', will not work
>>   properly.  It will not be possible to prepare or install
>>   groff-generated documentation in HTML format.

Robert Goulding
Director, John J. Reilly Center for Science, Technology, and Values;
Director, Program in History and Philosophy of Science;
Assoc. Professor, Program of Liberal Studies,
Fellow, Medieval Institute,
University of Notre Dame.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]