[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.0.14); tramp hangs when storing files >1000 bytes

From: Bjørn Nordbø
Subject: Re: tramp (2.0.14); tramp hangs when storing files >1000 bytes
Date: 01 Sep 2002 12:00:30 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

address@hidden (Kai Großjohann) writes:
> No, no.  That's not what I meant.
> You have to interactively log in to the remote host by doing

Ah, ok. Well, I tried that and it worked fine (started Emacs and a
shell buffer and yanked the uuencoded data into the standard in of
the uudecode-process. It seemed to work fine.

I have done some more testing:

- Have tested real.hosts being both Solaris 8 and Debian GNU/Linux;
  no difference.
- The problem seems to occur as the file goes above 1005 bytes. I
  have tested this several times; 1005 bytes is of, 1006 bytes and
  it hangs.
- I have found no runaway processes on any of the hosts, just a
  chain of [emacs -> ssh] -> [sshd -> bash -> ssh] -> [sshd -> sh]
  where everybody seems to be expecting some kind of response from
  somewhere (the last shell hangs on read from FD 0).

However there's one thing that troubles me. Even though I use the
"multi" method (which should use mimencode) and has set mimencode
as tramp-encoding-command and tramp-decoding-command, it seems from
the debug buffer that Tramp still uses uudecode. Hmm.

Thanks again for you answers.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]