[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp and FreeBSD

From: Rommel Martinez
Subject: Re: Tramp and FreeBSD
Date: Mon, 18 Feb 2008 20:41:46 +0800

On Feb 18, 2008 8:21 PM, Michael Albinus <address@hidden> wrote:
> "Rommel Martinez" <address@hidden> writes:
> > I've tried changing shell on the remote account. I've tried changing it to
> > Csh, Bash, and Sh. I then Tramp'd to the remote server, and it
> > worked, all except Zsh.
> Zsh is famous in disturbing Tramp. Read the Tramp manual:
>   (info "(tramp)Frequently Asked Questions")
> You need the following line in your ~/.zshrc on the remote host:
>   [ $TERM = "dumb" ] && unsetopt zle && PS1='$ '
> Best regards, Michael.

I did as you suggested. When I open a remote file on the
server using Tramp, I get this:

Couldn't `exec env 'ENV=' 'PS1=$ ' /bin/sh', see buffer `*tramp/ssh 

*tramp/ssh address@hidden contains:


A dollar sign, then a space.

Rommel M. Martinez <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]