[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

tramp connection problem on windows with plink (incl. workaround)

From: Thomas Bleier
Subject: tramp connection problem on windows with plink (incl. workaround)
Date: Tue, 25 Nov 2008 13:08:41 +0100


I had problems with tramp connecting to various linux hosts because of the "multiple prompts after the stty" problem that was already discussed some time ago on this list (at least according to the archives). None of the approaches discussed (sending igncr, changing language-environment) worked for me, so I found another workaround, that may be helpful to others, so I'd like to share it here.

Problem was that tramp timed out connecting to a linux host, with the error message "Couldn't stty -inlcr -echo kill..", the debug buffer shows '... not found in 30 secs'. Environment is Windows Vista SP1 german, Emacs 22.3.1 (also did not work with 22.2 before), trying to connect to various linux hosts with CentOS 5.2 (RHEL 5 clone) and Ubuntu 8.04.

Looking at the debug buffer the response from the server obviously contained multiple prompts ("$ "), after the stty command, which the default tramp-shell-prompt-pattern is unable to handle. Futher more, different linux variants seem to produce a different number of prompts... Other posts as mentioned above tried to fix the problem at the root, but did not work for me, so I just did a quick workaround by adapting the tramp-shell-prompt-pattern using

(setq tramp-shell-prompt-pattern "^[^#$%>\n ]*\\(\\$ \\)*[#$%>] *\\(\e\\[[0-9;]*[a-zA-Z] *\\)*")

in my .emacs (instead of the default "^[^#$%>\n]*[#$%>] *\\(\e\\[[0-9;]*[a-zA-Z] *\\)*").

Seems to work in my setup, but I'm not sure if it has any other side effects.

best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]