[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; tramp does not do a direct copy when it should

From: Nicholas Gianniotis
Subject: Re: tramp (; tramp does not do a direct copy when it should
Date: Fri, 19 Jul 2019 10:40:22 +0300

Hi Michael,

Thanks again for looking into this.

>> In the meantime, I am wondering if perhaps this setting is messing things up?
>> '(tramp-copy-size-limit 102400 nil (tramp))
> Don't know, will check. But as said, I couldn't reproduce the incrimed
> behavior locally.
> Have you changed the value? The default value is 10240.

Yes, I changed the value.

Another thing that might be relevant is the remote host is a Solaris 10 
machine. I seem to recall some other Tramp posts where people had issues with 
the shell or the prompt on Solaris 10 hosts. Don’t know if that’s relevant in 
this case.

I tried to re-run the test case as you instructed, but I didn’t get very far. 
Tramp reported a timeout when I tried to connect to the remote host (I 
confirmed with ssh that the host is up).

I’ve attached some screenshots of what happened when I tried to visit the file 
“/-:hyper-m.wan:”. The host “hyper-m.wan” is defined in my ~/.ssh/config file. 
I do not allow ssh password access, all remote host authorization is done via 
public keys and authorized_hosts.

PNG image

PNG image

PNG image

As you can see above in the *tramp/scp hyper-m.wan* buffer, a login shell has 
been established on the remote host. But Tramp timed out.

Finally Tramp reports:

PNG image

The contents of the *trace-output* buffer are attached. That’s a lot of diag 
output :-)

I also have attached all the tramp-related configs in my .emacs. I use tramp 
quite extensively to access remote Linux, MacOS and Solaris hosts, so over the 
years I have had to do a lot of tweaking.

Thanks again,

Description: Zip archive

Description: Zip archive

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

reply via email to

[Prev in Thread] Current Thread [Next in Thread]