[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; tramp does not do a direct copy when it should

From: Michael Albinus
Subject: Re: tramp (; tramp does not do a direct copy when it should
Date: Mon, 22 Jul 2019 14:44:21 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Nicholas Gianniotis <address@hidden> writes:

> Hi Michael,

Hi Nicholas,

> Another thing that might be relevant is the remote host is a Solaris
> 10 machine. I seem to recall some other Tramp posts where people had
> issues with the shell or the prompt on Solaris 10 hosts. Don’t know if
> that’s relevant in this case.

Likely not. Tramp does not care the OS of the remote host, when it
decides to apply a direct scp command.

> I tried to re-run the test case as you instructed, but I didn’t get
> very far. Tramp reported a timeout when I tried to connect to the
> remote host (I confirmed with ssh that the host is up).
> I’ve attached some screenshots of what happened when I tried to visit
> the file “/-:hyper-m.wan:”. The host “hyper-m.wan” is defined in my
> ~/.ssh/config file. I do not allow ssh password access, all remote
> host authorization is done via public keys and authorized_hosts.
> As you can see above in the *tramp/scp hyper-m.wan* buffer, a login
> shell has been established on the remote host. But Tramp timed out.

That's a pity. Your previous attempts have worked, right?

> Finally Tramp reports:
> The contents of the *trace-output* buffer are attached. That’s a lot
> of diag output :-)

Yes, but unfortunately nothing about the problem in question. I need the
traces, when Tramp has copied something.

Could you try to solve the connection problem, and produce new traces?

> I also have attached all the tramp-related configs in my .emacs. I use
> tramp quite extensively to access remote Linux, MacOS and Solaris
> hosts, so over the years I have had to do a lot of tweaking.

That's not too much, most of it are comments :-)

Btw, the comint-input-ring-file-name hack won't be needed any longer
when you switch to Emacs 27. I have fixed shell-mode that it also
supports remote shell history files.

> Thanks again,
> Nico

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]