[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Axiom-developer] GCL-2.6.8pre unable to make new image

From: Page, Bill
Subject: RE: [Axiom-developer] GCL-2.6.8pre unable to make new image
Date: Wed, 30 Aug 2006 03:37:25 -0400


It's too late for the midnight oil isn't it? ;)

As I understand it --enable-ansi in GCL does not require
that the source be ansi compliant but rather builds several
variants of the gcl binary, one of which is ansi compliant.

There is the GCL_ANSI env variable mentioned by Camm here:

whose abscense tells gcl to run in the non-ansi image.

At least, I did not get any error messages that specifically
suggested problems with non-ansi source.

Note especially Camm's suggested plan towards the end of his

> 1) Mod GCL to
>    1) build axiom as is under ansi.  This is a simple conversion
>    of the in-package failure to a warning afaict. or 
>    1a) ship both images starting with 2.6.8 everywhere.
>    2) remove compile-time memory limits in GCL.

Camm recently complete 2). I am not sure of the other items.

Bill Page.

> -----Original Message-----
> From: root [mailto:address@hidden 
> Sent: Wednesday, August 30, 2006 3:10 AM
> To: address@hidden
> Cc: address@hidden; address@hidden; 
> address@hidden; address@hidden
> Subject: Re: [Axiom-developer] GCL-2.6.8pre unable to make new image
> clearly burning the midnight oil, eh?
> > --enable-ansi fails with:
> Axiom won't work in an ansi lisp yet. 
> t

reply via email to

[Prev in Thread] Current Thread [Next in Thread]