[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-AUCTeX] Re: 11.85; Biblatex vs. RefTex

From: Matthew Lundin
Subject: [Bug-AUCTeX] Re: 11.85; Biblatex vs. RefTex
Date: Fri, 05 Jun 2009 08:27:30 -0500
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (darwin)

Andreas Breitbach <address@hidden> writes:

> Am Mittwoch, den 03.06.2009, 19:21 +0200 schrieb Ralf Angeli:
>> * Andreas Breitbach (2009-06-02) writes:
>> > I'm using Biblatex instead of Bibtex, for which AucTex/RefTex seems to
>> > be preconfigured. The basic functions like inserting citations,
>> > bibliographies and so on work quite well. But there's some very strange
>> > behavior when i use the folowing lines in my .emacs
>> > (setq reftex-cite-format "\\footcite[]{%l}")
>> > (setq reftex-cite-prompt-optional-args t),
>> > all i do get is "reftex-do-citation: Args out of range: 21, 37"(I think
>> > the numbers change from time to time...). The expected behaviour would
>> > be to insert the optional argument(which follows the citation, ie. a
>> > page number) after the citation.
>> Does it work with the latest released version of RefTeX (available from
>> its home page) or even a CVS checkout?  (You might have to wait a bit
>> for the RefTeX repository to become available again after the Savannah
>> outage.)
> No, still doesn't work. I tried the CVS, and the error stays the same.
> Is there any way I could get a trace for others to debug, or some other
> way for getting a more detailed description of what's happening? 

I tried these settings with reftex-cvs and Carbon Emacs -- GNU Emacs
22.3.1 (i386-apple-darwin9.6.0, Carbon Version 1.6.0).

I cannot duplicate the error. The footcite macro was inserted as
expected and I was prompted for an optional argument.

I hope you find the source of the problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]