bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31169: 26.1; Emacs 26.1 RC1 (gtk) display issues over SSH/X11 with x


From: Eli Zaretskii
Subject: bug#31169: 26.1; Emacs 26.1 RC1 (gtk) display issues over SSH/X11 with xming/vcxsrv
Date: Tue, 17 Apr 2018 05:34:58 +0300

> From: charlie hemlock <address@hidden>
> Date: Mon, 16 Apr 2018 19:37:44 -0400
> Cc: address@hidden
> 
> > Is this all you see in the Emacs frame?  It looks like a part of a
> > frame , did you clip the image, perhaps?  If so, please show all of the 
> > frame. 
> 
> That was all the frame. Including new attachment [emacs26_gtk3.png] for 
> clarity. (show a little of background
> and putty window). I tried resizing window and same result.
> 
> > To make sure this is related to GTK, could you try building with a
> > different toolkit, just to see if that build starts as expected? 
> 
> Attached with "motif" x-toolkit screenshot. [emacs26_motif.png].
> Appears OK,  but I can't ./configure --with-xwidgets 

The Motif frame looks better, but still not entirely normal: what's
that empty space to the right of the window?

Is that similar to what you see locally on the GNU/Linux box?

>   > Does it eat CPU cycles?  
> No - just looked a 'top' output.
> 
> > Can you exit it with "C-x C-c" or do you have to kill it by a
> signal?  
> C-x C-x works.

If "C-x C-c" works, then does "M-x redraw-display RET" redraw the
frame to its normal appearance?

What about "C-x 5 b RET" -- does it create a new frame, and does that
frame look correctly?

Thanks.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]