bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31169: 26.1; Emacs 26.1 RC1 (gtk) display issues over SSH/X11 with x


From: charlie hemlock
Subject: bug#31169: 26.1; Emacs 26.1 RC1 (gtk) display issues over SSH/X11 with xming/vcxsrv
Date: Thu, 19 Apr 2018 19:41:33 -0400

> And according to the table you show, those menu problems are resolved
> in a later version of GTK+, is that right?

I believe so, CentOS 7 still has menu issues.
& I did see other oddness -  but still definitely better with inhibit-double-buffering


loading with init.el that only contains:
modify-frame-parameters nil '((inhibit-double-buffering . t)))

emacs -q -l ./init.el


CentOS7, gtk: 2.24.31,  gtk3: 3.22.10
| emacs      | VcXsrv                           |
| 25.3  gtk2 | ok                               |
| 25.3  gtk3 | ok, no emacs logo, menus no show |
| 26.1  gtk2 | ok                               |
| 26.1  gtk3 | ok, no emacs logo, menus no show |

OpenSUSE Leap 42.3 , gtk2: 2.24.31,  gtk3: 3.22.10
| emacs      | VcXsrv                    |
| 25.3  gtk2 | ok                        |
| 25.3  gtk3 | ok, but no emacs logo (1) |
| 26.1  gtk2 | ok                        |
| 26.1  gtk3 | ok, but no emacs logo (1) |


OpenSUSE Tumbleweed, gtk2: 2.24.32,  gtk3: 3.22.29
| emacs      | VcXsrv                    |
| 25.3  gtk2 | ok                        |
| 25.3  gtk3 | ok, but no emacs logo (2) |
| 26.1  gtk2 | ok                        |
| 26.1  gtk3 | ok, but no emacs logo (2) |


(1)  "About GNU" launches external browser when in ssh
remote session. But "M-x eww gnu.org" will display in eww mode. 
Additionally, local emacs session uses Eww mode for the about pages, and
displays emacs logo.

(2) "About GNU" launches non-emacs text editor of .html when in ssh
remote session. But "M-x eww gnu.org" will display in eww mode. 
Additionally, local emacs session does use Eww mode for About GNU.
but also opens the .html into non-emacs text editor (gedit), and does not display emacs logo at startup.

On Thu, Apr 19, 2018 at 2:47 AM, Eli Zaretskii <address@hidden> wrote:
> From: Noam Postavsky <address@hidden>
> Date: Wed, 18 Apr 2018 21:27:40 -0400
> Cc: address@hidden
>
> charlie hemlock <address@hidden> writes:
>
> > However, in Centos7 (with vcxsrv), the file menus don't appear OK when
> > clicked as previously reported (see gtk errors in previous posts) A
> > different issue?
>
> Yeah, the other bug specifically mentions that menus work fine, so it
> sounds like you're hitting some other issue as well.

And according to the table you show, those menu problems are resolved
in a later version of GTK+, is that right?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]