[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Text drawing bug - gaps after 16th character in scaled view

From: Kazunobu Kuriyama
Subject: Re: Text drawing bug - gaps after 16th character in scaled view
Date: Tue, 01 Jul 2003 01:18:40 +0900
User-agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.0.0) Gecko/20020614

Pete French wrote:

xwd(1) and xwud(1) are the utilities accompanied with X11R6.

O.K. - just took a look at that. Ugh! Thats very wrong. Was that with
the ART backend or the XLIB one ?

That is the xlib backend.  Though the image tells nothing about gaps
I've also experienced it with another program.

I tried it with a few fonts of different sizes, and got the same results.
What is strange is that some applications display strings correctly while
the other ones not.  When I changed the string of that program, it sometimes
worked fine.  It seemingly depends on the length of a given string.  But
I could not find any behavioral order.

Its not the same bug aas the one I get, but its certainly *a* bug. I have
just tried allmy code here with the latest CVS though (unsing the 'art'
backend) and my problem with the ends of strings in alert panels has gone

Does it mean that the GNUstep's code is changed, or that you changed the code
of your own program in accordance with the previous discussions so far?

try it with the latest CVS coode and AT backend and see what happens.


OK, I will.  To do that, I need to reinstall freetype library so that it
has the symbols FTC_*.  It may sound strange to you, the freetype library
I have has no such symbols and thus failed to compile the art backend.
So I'm afraid it will take one or two days to report the result to you.

Thank you.
Kazunobu Kuriyama

reply via email to

[Prev in Thread] Current Thread [Next in Thread]