[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] The lilypond build system adopted to build Denemo for

From: Richard Shann
Subject: Re: [Denemo-devel] The lilypond build system adopted to build Denemo for various OS
Date: Sun, 05 Jul 2009 16:28:22 +0100

On Sun, 2009-07-05 at 15:08 +0100, Richard Shann wrote:
> > > it.
> > 
> > Yup, that would be nice.
> This was as I remember (see my earlier email) - just "lilypond" works.
> I'll download the 40 MB thing on a Windows box I have access to and
> see
> if I can find out what is happening.

Ok, I have done that, the denemo is running under Windows Vista, with
these problems

1)  starting with that cryptic warning that some icons won't show - and
indeed on choosing view->articulation palette you find the ones in
question, the palette just has little boxes. These are the icons
generated by .svg images for which gtk does not have a built in loader. 
I had this problem with my hand-build of denemo for window. It was the
installation of the gtk stuff that was faulty. To fix this problem I had
include the svg loader .dll in the package and to arrange for the
installer to run the executable  gdk-pixbuf-query-loaders piping the
output to the pixbuf loaders file. There was another executable to run
as well ( *modules*...)

2) None of the scripts are installed, nor their associated bitmaps and
editscripts that is there are no directories


This is no doubt to do with the fact that they are installed en masse -
anything dropped into these directories is copied to

without being explicitly mentioned in any makefile.

3) The denemo.ttf font is not installed. Hence the note and rest entry
toolbar having a series of numbers and letters instead of notes and

4) None of the process spawing works - no MIDI playback or running of
LilyPond. This will again be a gtk installation problem, I had this
problem as well once when I cut down what I thought were useless extras
in the bin directory. I hadn't copied the spawning helper programs that
gtk uses to do the spawning, and looking just now I cannot find any
programs with spawn in their name under GNU_denemo (this is windows, so
it is painful to find out). 

So I think the gtk stuff is not properly installed and not quite all the
denemo stuff is installed. But it is very close.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]