[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Try to improve E100's performance at high sample

From: ziyang
Subject: Re: [Discuss-gnuradio] Try to improve E100's performance at high sample rate
Date: Wed, 25 Jan 2012 18:37:26 +0100
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110419 Thunderbird/3.1.9

On 01/24/2012 11:00 PM, Philip Balister wrote:

This is what it shows when I run a "opkg list-installed | grep orc" check:

liborc-0.4-0 - 0.4.16-r1.0.9
liborc-test-0.4-0 - 0.4.16-r1.0.9
orc - 0.4.16-r1.0.9

I don't understand why orc/liborc cannot be detected by CMake. The
options for CMake are:

-DCMAKE_CXX_FLAGS:STRING="-mcpu=cortex-a8 -mfpu=neon -mfloat-abi=softfp
-g" -DCMAKE_C_FLAGS:STRING="-mcpu=cortex-a8 -mfpu=neon
-mfloat-abi=softfp -g" ../

Could you tell me what might be the problem? Thanks.
Add -DENABLE_ORC=ON to the cmake command line.


Thanks, Philip. But the problem remains after -DENABLE_ORC=on is added. When configuring volk, these issues are reported:

-- Configuring volk support...
--   Enabling volk support.
--   Override with -DENABLE_VOLK=ON/OFF
-- Boost version: 1.45.0
-- Found the following Boost libraries:
--   unit_test_framework
-- checking for module 'orc-0.4'
--   package 'orc-0.4' not found
-- orc files (missing:  ORC_LIBRARY ORC_INCLUDE_DIR)
-- Performing Test have_maltivec
-- Performing Test have_maltivec - Failed
-- Performing Test have_mfpu=neon
-- Performing Test have_mfpu=neon - Success
-- Performing Test have_mfloat-abi=softfp
-- Performing Test have_mfloat-abi=softfp - Success
-- Performing Test have_funsafe-math-optimizations
-- Performing Test have_funsafe-math-optimizations - Success
-- Performing Test have_m32
-- Performing Test have_m32 - Failed
-- Performing Test have_m64
-- Performing Test have_m64 - Failed
-- Performing Test have_m3dnow
-- Performing Test have_m3dnow - Failed
-- Performing Test have_msse4.2
-- Performing Test have_msse4.2 - Failed
-- Performing Test have_mpopcnt
-- Performing Test have_mpopcnt - Failed
-- Performing Test have_mmmx
-- Performing Test have_mmmx - Failed
-- Performing Test have_msse
-- Performing Test have_msse - Failed
-- Performing Test have_msse2
-- Performing Test have_msse2 - Failed
-- orc overruled
-- Performing Test have_msse3
-- Performing Test have_msse3 - Failed
-- Performing Test have_mssse3
-- Performing Test have_mssse3 - Failed
-- Performing Test have_msse4a
-- Performing Test have_msse4a - Failed
-- Performing Test have_msse4.1
-- Performing Test have_msse4.1 - Failed
-- Performing Test have_mavx
-- Performing Test have_mavx - Failed
-- Available arches: generic;neon
-- Available machines: generic;neon
-- Did not find liborc and orcc, disabling orc support...
-- Using install prefix: /usr/local
-- Could NOT find Doxygen (missing:  DOXYGEN_EXECUTABLE)

However, if I check orc manually with "opkg list-installed | grep orc", it shows:

liborc-0.4-0 - 0.4.16-r1.0.9
liborc-test-0.4-0 - 0.4.16-r1.0.9
orc - 0.4.16-r1.0.9

And if I run a search for orc under /usr , these related files are found:


So I guess it's because the installation of orc is not complete. I wrote a orc-0.4.pc, something like this:

Name: orc-0.4
Description: Oil Runtime Complier
Version: 0.4.16
Libs: -L${libdir} -lorc-0.4
Libs.private: -L/usr/lib
Cflags: -I${includedir}


and put it in /usr/lib/pkgconfig, copy orc.h to /usr/include/orc-4.0/orc/ . Now ORC_INCLUDE_DIR can be found by FindORC.cmake, but ORC_LIBRARY, liborc and orcc are still missing. Is there any way to fix this or do I need a fresh rebuild of orc? Thanks.

Best Regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]