[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: thumbs.el and transparency

From: Mathias Dahl
Subject: Re: thumbs.el and transparency
Date: Sun, 29 Jan 2006 23:04:42 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

"Robert J. Chassell" <address@hidden> writes:

> My conclusion: Please combine Tumme Thumbnail mode with the current
> Thumbs mode, which is inadaquate as is.  For the most common
> invocation, please deploy one window in a frame that does not need
> to be widened.  This window should be a dired buffer.  It should
> show all the usual dired information (except maybe the links info)
> as well as the thumbnail images.  You should be able to invoke it
> when typing `M-x thumb'.  Also, the command `dired-thumb' should be
> aliased to `thumb'.

Before we decide any "drastic" solution like The Big Merge, please
consider the small additions and changes from my last couple of posts.

> That makes my dired window too narrow.  My default windows frame,
> run under X, produces a window that is eighty characters wide.  This
> works fine.  In a regular instance of Emacs with this Tummes
> configuration, I cannot see the endings of file in dired.  The
> window becomes 37 characters wide.  I had to widen the whole frame
> before I could even begin to mark files.

I see. Another configuration that I set up manually sometimes, is

 |     D        |
 | TB   |  DB   |
 |      |       |
D = dired
TM = thumbnail buffer
DB = display buffer

It has the advantage of not truncating the dired information.

> Also, I currently have 86 open buffers in this instance of Emacs,
> and do many different things.  So I did not want a program that adds
> too many windows.  I started a separate instance.

I understand.

> The one window beginning should be a dired window that also shows
> thumbnail images.

I like the idea but I'm not sure I would manage buliding such a beast

> In another instance, I tried `M-x thumbs'.  Tumme Thumbnail mode is
> not like Thumbs mode.

No, it's not. :)

> By default, Thumbs mode initially shows only thumbnails, not dired
> information plus thumbnails.  However, Tumme Thumbnail mode does not
> show any images at all when you type `M-x tumme-dired'.

Correct, but the new command I posted earlier in this thread
does. Check it out.

> How do I save such a resized image?  Using the normal commands, C-x
> h (`mark-whole-buffer') and M-w (`kill-ring-save'), I tried saving
> the smaller image as foo.jpg, but that did not work.  The file
> contained only two bytes, 0x20 0x0a, and the ImageMagick `display'
> program said it was not a JPEG file.

The sized image is stored using the file name in variable
`tumme-temp-image-file'. So you could copy that file to a new one, but
it would be better to provide such a command in the display buffer

>    If you want to see the full size image, either use C-x o to jump to
>    the display buffer and then press "f" (full) there, or press C-return
>    to display image in an external viewer (which must be
>    configured). Press "s" to again display a sized version.
> Neither succeeded in this instance of my regular Emacs.  (But see
> below.)  `f' (tumme-display-current-image-full) just displayed a
> small, empty box.

I noticed that box today too and then it was because Emacs does not
handle the image file type. What `f' does, although it just says
"display in full size bla bla) is really to just let Emacs try and
display the file. This could be fixed by converting the full size
original to a full size jpeg (which is what tumme always converts to),
but I am not sure that feels good.

> Also, `s' (tumme-display-current-image-sized) failed.  All I could
> see was the small, empty box and an error message that said "No
> original file name at point".

Hmm, I will try to recreate that, thanks!

> Ack!  I just deleted the tumme related buffers, ran `M-x
> tumme-dired', marked an image, moved dot to the *tumme* buffer by
> moving the mouse, pressed C-t d (`tumme-display-thumbs').  I do not
> see a thumb.  (For this instance, I have `mouse-autoselect-window'
> set to t in my initialization file, but that turns out to be
> irrelevant.)

No no. Don't move to the *tumme* buffer before running that command
(C-t d), run it from the Dired buffer. That should work much much
better! :)

> First I switch to the *tumme* buffer but `C-t d'
> (tumme-display-thumbs) fails.  So switch back to the dired buffer
> and run `C-t d' there.  That succeeds.  (So my earlier failure was
> not due to Mouse Autoselect mode, as I thought earlier.)
> Good, this time both `f' (tumme-display-current-image-full) and
> `C-RET' (tumme-thumbnail-display-external) succeed.
> So does `s' (tumme-display-current-image-sized).

Ah, good!

Now read my earlier posts too :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]