[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: --with-gtk as default?

From: David Kastrup
Subject: Re: --with-gtk as default?
Date: Tue, 27 Feb 2007 23:21:46 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.94 (gnu/linux)

David Kastrup <address@hidden> writes:

> Nick Roberts <address@hidden> writes:
>>  > > I don't have an opinion about this, but if we eventually do
>>  > > make this the default, please exclude Cygwin from the
>>  > > platforms that build with GTK+ by default, because as Jan
>>  > > discovered, the Cygwin build is currently incompatible with
>>  > > GTK+.
>>  > 
>>  > Cygwin is basically an X11 build?
>> I guess the various distributions will build Emacs with GTK, anyway.
> The evidence is against you here.  There are already emacs-snapshot
> packages for Debian GNU/Linux and derivatives, and to get a version
> for GTK+ you _explicitly_ have to install emacs-snapshot-gtk.
> Otherwise you will get the Athena widget version.
> I don't see where you get the conviction that things will change with
> the release of Emacs 22 _unless_ we express our "upstream" intent to
> have GTK+ preferred over Athena in a default installation by, well,
> making it the default installation.

Of course, only when we can reasonably expect it to work which would
appear to exclude the Cygwin environment Eli mentioned.

Mainly because I am nosy I'd still be interested in knowing whether
that is basically an X11 environment, or possibly just the Gtk+ widget
set without using the underlying X server infrastructure probably
provided by Cygwin.


David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]