[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Re: [Orgmode] customising org-latex-to-pdf-process for bibtex

From: Eric S Fraga
Subject: [O] Re: [Orgmode] customising org-latex-to-pdf-process for bibtex
Date: Wed, 02 Mar 2011 06:55:54 +0000
User-agent: Gnus/5.110014 (No Gnus v0.14) Emacs/24.0.50 (gnu/linux)

Suvayu Ali <address@hidden> writes:

> Hi Eric,
> On Tue, 01 Mar 2011 20:41:20 +0000
> Eric S Fraga <address@hidden> wrote:
>> Ah, very interesting.  What I don't understand is why this is
>> affecting you.  I can see it affecting you if the aux file cannot be
>> found but not if the first pdflatex step worked okay.  Do you still
>> have the problem if the first step worked?
> Before the first pdflatex run the working directory seems correct:
>> Invoked in dir  /home/jallad/org/masters-thesis
> In the output for this run I see some lines like these:
>> [6]
>> No file msthesis.bbl.
>> [7] (./msthesis.aux)
> I guess that means the .aux files are created?

Well, actually, this indicates that the aux file is being read by
pdflatex.  But obviously it must exist therefore...

>> If so, and if you still have the sh file I sent to the list yesterday,
>> can you add the following line to the top:
>> echo 'Invoked in dir ' $PWD
>> and post the output (the first few lines only) of the export to PDF
>> when you get the error with bibtex?
> Despite the above, for bibtex I get the following:
>> --------------------------------- running bibtex next
>> Invoked in dir  /home/jallad/org/masters-thesis
>> bibtex: Not writing to /home/jallad/org/masters-thesis/msthesis.blg
>> (openout_any = p). I couldn't open file name
>> `/home/jallad/org/masters-thesis/msthesis.blg'

Oh well, there goes that theory.  The web link you gave yesterday would
seem to indicate that the problem is present if you invoke the bibtex
command from another directory and this does not appear to be the case
here.  Very strange.

> Explicitly calling the texlive 2007 bibtex resolves the problem.

Well, at least you can get this working for now but obviously there is a
problem we are going to have to sort out as more users move to 2010.  I
am using texlive 2009 on Debian and that version doesn't have this
problem.  Texlive 2010 isn't available (yet) for Debian even in unstable
so I cannot easily test this out unfortunately.  I'll have a look to see
if it's in Debian's experimental distribution when I get a chance.

: Eric S Fraga (GnuPG: 0xC89193D8FFFCF67D) in Emacs
: using Org-mode version 7.4 (release_7.4.576.g99675)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]