[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Gcl-devel] Problem installing Gcl under Windows

From: Mike Thomas
Subject: RE: [Gcl-devel] Problem installing Gcl under Windows
Date: Wed, 5 Jan 2005 07:00:48 +1000

Hi there (Is your name Shikram?).

Thanks for replying.  I've CC'ed the mailing list to make sure our work is
recorded for others to use.

I wrote:

| > Could you please check that you have write permission to that directory
| > tree?
| >
| > Could you also please try installing to the default location
| (that is, don't
| > modify the default installation path when the installer runs)
| and see what
| > happens?

You replied:

| I 've already tried this alternatives. I started the installation
| as Administrator as always I do. Well I always work logged as
| Administrator. I tried to install both in the default directory
| and in a custom one (for example C:\gcl) but happens the same
| problem. I don't think there is a write permission problem
| in this directories, because the files are copied succesfully by
| the installation program.
| The first line in the shell screenshot I've attached in my
| previsious email is not a real command because it follows "echo",
| but the syntax is a lisp command that try to create the modified
| file. So the installation program try to execute a lisp command
| and print a dummy string of the commanda executed

Yes - echo sends two lisp commands through a pipe to be executed by
"saved_ansi_gcl.exe".  The first lisp command sets the *system-directory*
variable.  The second lisp command saves the Lisp system out as

| or try to
| execute the command from the shell?


| If the first event occurs probably the
| program try to execute a lisp command but doesn't work for some
| reason.

Yes.  Perhaps because

  1) the executable didn't exist (Probably not or del would have given an
error when it ran),

  2) the lisp commands are buggy on your system, or

  3) "modifed.exe actually exists but went to the wrong location (search the
disk for "modified.exe" to check this).

| How it is executed that commad? From the lisp interpreter?


| So can you send me a .c file that executes the same commands
| executed in the shell?
| In this way I can see what resorces ((files ecc. ) the
| installation program uses.

I haven't time at the moment to write and check such a program but you
shouldn't need it anyway - by typing the sequence of commands at a Windows
command prompt you should get the same results as those commands are running
in a command shell.

Unfortunately "saved_ansi_gcl.exe" has probably been deleted because that
part of the script seems to have run properly.  Please check that this is

If "saved_ansi_gcl.exe" is missing, please let me know where I might be able
to FTP a new one to you (unless you can accept an 8 Meg zipped file by email
without upsetting your virus protection software.)

| I use gcc as compiler with mingw32 libraries.

Great.  This will allow you to build gcl from the source if needed - I would
be pleased to help you get set up and running.  Which version of MSYS, gcc
and binutils are you using?


Mike Thomas.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]