[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Mon, 2 Jul 2001 09:59:53 +0200 (MEST)
On 1 Jul 2001, Marius Vollmer wrote:
> As to renaming scm_c_read_string and scm_c_eval_string, couldn't they
> be seen as C variants of Scheme primitives? I'd say that str and mem
> are mostly for type conversions, like mem2symbol or mem2string.
Hmmm. In a way, yes. You could argue that it is not very much different
from the situation with scm_make_vector and scm_c_make_vector, where the
only difference is, that the length of the vector is given as a unsigned
long int instead of a SCM value.
But, the point which makes it debatable for scm_c_eval_string is, that in
this case the datatype itself (or at least so one could argue) is part of
the function name.
I am not sure myself. It may be that a name like scm_c_eval_str would
make the usage of the function more obvious for people that are aware of
our naming convention. But that's just an assumption. If, however, we
are once providing a scm_c_eval_mem, well, then it is more obvious that
the string/str really indicates a data type rather than a general concept.