[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-19.34 segfauls when built with Xfree 4.3.0 (glibc 2.3.x,gcc 3

From: Hin-Tak Leung
Subject: Re: emacs-19.34 segfauls when built with Xfree 4.3.0 (glibc 2.3.x,gcc 3.2)
Date: Mon, 12 May 2003 15:40:22 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

That's a somewhat time-wasting question - if I am on linux with
gcc 3.2 glibc 2.3.x and Xfree 4.3.0 most certainly the linux
distribution I use come with a more recent version of emacs or xemacs.
(actually both). And my original post mentioned that I built emacs-19
successfully on a Xfree 4.1/glibc 2.0/2.1 system as well,
and that binary still works on the current system.

I want to use a elisp script called cemacs (for Chinese inputs)
but unfortunately the inclusion the MULE (Multi-lingual Extension)
since version 20 has broken it. It does continue to work with
xemacs-21.x, but that's besides the point.

Now back to my question: why emacs 19.34 segfault when built against
glibc-2.3 and Xfree 4.3.0? And please stick to the question... -
and please do not ask why I don't switch to xemacs, or use MULE.

Just to anticipate these two questions: MULE is no where as good
as cemacs (unfortunately, and please don't start an argument on why I
should use MULE even though it is inferior), and xemacs is too
bloated for my taste. So I would really rather try to keep using
a small installation of 19.34 (in addition to emacs 21 which came
with the distro), or port cemacs forward to emacs 21 (quite major
work, probably). The 2nd option is probably better for long
term, but until it is done, I will continue to try to build emacs
19 on current systems... and I would really like to find out
why it won't build.

Hin-Tak Leung wrote:
I am trying to build emacs-19.34 against glibc-2.3 and Xfree 4.3.0
on linux with gcc 3.2. The binary works with -nw switch, but
when I run it without -nw, it segfaults with Fatal Error(11).
So it seems to be an X-related problem.

have you tried using a more recent version of emacs? emacs-21.3.1 is
what i use and it compiled with gcc-3.2.3 on XFree86-4.3 no problems
(glibc-3.2.3) using using Lesstif-0.93.41. unless there is some reason
you WANT to use an older version?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]