help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: using use-package


From: John Mastro
Subject: Re: using use-package
Date: Thu, 13 Aug 2015 15:12:52 -0700

<address@hidden> wrote:
> ... the only version of magit to hit my computer was this one loaded
> via ELPA (once). Unless I fat-fingered something (does happen
> sometimes).

If you started with 1.4 and upgraded to 2.1 (all via ELPA), errors are
possible/likely. Magit's maintainer recommended first uninstalling 1.4
and then installing 2.1 [1].

Michael Heerdegen <address@hidden> wrote:
> If the issue is reproducible, it could be worth to report it to the
> Magit maintainers.  In my special case, it was fixable from the Magit
> side.
>
> BTW, AFAICT since Helm uses async.el for package upgrading we have had
> no more of such problems.

Magit is now using async.el as well, and for the same reason [2].

[1] 
http://magit.vc/manual/magit/Updating-from-an-older-release.html#Updating-from-an-older-release
[2] 
https://github.com/magit/magit/commit/42e4632ed4925fc65f95ff03e55e80d04e62ffb2

-- 
john



reply via email to

[Prev in Thread] Current Thread [Next in Thread]