help-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pl2link error while installing application? [MacOS problem]


From: Adam Fedor
Subject: Re: pl2link error while installing application? [MacOS problem]
Date: Tue, 6 Jun 2006 14:05:34 -0600

That's probably due to this problem:

http://www.gnustep.org/resources/documentation/User/GNUstep/ userfaq_1.html#SEC25


On Jun 6, 2006, at 2:00 PM, Daniel J Farrell wrote:

Hi everyone,

Almost there now, I have Affiche compiled and running locally! That is to say the 'sudo make' command got far enough to compile everything fine so that I can run the app from it's directory:

openapp ./Affiche.app

However when ever I try to 'make' I'm still getting this strange error pl2link error/ dynamic library not loading (see below). Has anybody else here installed this using DarwinPorts. gnustep is a great environment I'd love to start using it.

Regards,
        Daniel

PS - here is the error I get when I try to sudo make an app:

Daniel$ ~/Desktop/gnustep/Affiche Daniel$ sudo make

Making all for app Affiche...
Creating Affiche.app/Resources/Affiche.desktop...
dyld: Library not loaded: libgnustep-base.dylib.1.12
  Referenced from: /opt/local/GNUstep/System/Tools/pl2link
  Reason: image not found
make[1]: *** [Affiche.app/Resources/Affiche.desktop] Error 133
make: *** [Affiche.all.app.variables] Error 2



On 6 Jun 2006, at 06:00, Adam Fedor wrote:

Well, localhost0:0:0 isn't a valid display name. It should be something like hostname:#.#

localhost:0.0

or even

:0.0

should almost always work on a local display. I wonder how you display name got set to that?
to set:

export DISPLAY=:0.0


On Jun 5, 2006, at 4:28 PM, Daniel J Farrell wrote:

Hi Fred,

Yeah it's kind of encouraging! Now after running X11 (I assume all I have to do is open the X11 terminal) first I get a message saying:

fatal error: could not open display localhost0:0:0

So should be a simple case of just setting this correctly. I haven't been able to find what to set this too for mac os; any ideas?

Dan.


On 5 Jun 2006, at 19:45, Fred Kiefer wrote:

This looks much better than I did expect. Most likely you just did
forget to start the X server here.

But where does the pl2link problem then come from?

Fred

Daniel J Farrell schrieb:

The result is what looks like a windowing system error (see below).

Does this mean that everything is working but I just need to set the
display variable?

Regards,
    Daniel.

PS - Result from running the app locally:

~/Desktop/gnustep/Affiche Daniel$ openapp ./Affiche.app

_X11TransSocketINETConnect() can't get address for localhost0:0:6000: No
address associated with nodename
/Users/Daniel/Desktop/gnustep/Affiche/Affiche.app/Affiche: Uncaught
exception WindowServerCommunication, reason: Unable to connect to X
Server `localhost0:0:0'





_______________________________________________
Help-gnustep mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/help-gnustep




_______________________________________________
Help-gnustep mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/help-gnustep





reply via email to

[Prev in Thread] Current Thread [Next in Thread]