[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gettext later than 0.17?

From: Simon Josefsson
Subject: Re: gettext later than 0.17?
Date: Sun, 01 May 2011 22:17:17 +0200
User-agent: Gnus/5.110016 (No Gnus v0.16) Emacs/23.2 (gnu/linux)

address@hidden (Ludovic Courtès) writes:

> Hi Simon,
> Simon Josefsson <address@hidden> writes:
>> I notice the package 'gettext_0_17' exists and is (unsuprisingly)
>> gettext 0.17.  Is there a gettext_0_18 or even better gettext_0_18_1
>> package?
> Yes.
>> Is there any reason many packages depend on gettext_0_17 and not a
>> more recent version of gettext?
> In November 2010, Rob changed several Gnulib-using packages to
> explicitly depend on 0.17 instead of 0.18.  ISTR that Gnulib required
> the older version back then.

Hi Ludo!  I don't think that is the case any more.  DEPENDENCIES says:

* GNU gettext 0.16.1.

but I think that should be 'or newer', will ask on bug-gnulib...

> Anyway, which packages do you want to switch to 0.18?

Libidn and gsasl.  They have a AM_GNU_GETTEXT_VERSION([0.18.1]) in them
now, so they don't build any more.  The reason is to solve some
portability problems -- it turned out that using
AM_GNU_GETTEXT_VERSION([0.17]) made gettextize pull in *.m4 files from
the 0.17 era rather than the latest version (through its CVS/git archive
of older files).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]