[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compile problem with 2.8.4

From: Dave Phillips
Subject: Re: compile problem with 2.8.4
Date: Thu, 29 Jun 2006 06:54:39 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060209 Red Hat/1.7.12-0.90.2.legacy

Jan Nieuwenhuizen wrote:

Hi Dave,
Hi Jan, thanks for the reply.

error: GUILE signaled an error for the expression beginning here
(use-modules (scm display-lily))invalid module name for use-syntax
((srfi srfi-39))
Can anyone tell me what's going on ? Guile is version 1.6.8.

I haven't got a clue, but googling for this error brings me to

That is odd, because this fix was applied to 2.7.8.  What does your


say at that position?  It should be

   %% FIXME: guile-1.7 required?
   %#(use-modules (scm display-lily))invalid module name for use-syntax ((srfi 

   #(use-modules (scm display-lily))
   #(display-lily-init parser)
   displayLilyMusic =
   #(define-music-function (parser location music) (ly:music?)
      (display-lily-music music)
I have exactly the same code at that point. Perhaps I should try it with Guile 1.7 ?

Btw, this problem arose after upgrading to Xorg 7. It's been a mess since then, some of my GTK1 apps have terrible fonts now and I can't find out how to fix that problem. Is there anything in an X upgrade that would initiate the problem with Guile ? Bindings maybe ?




reply via email to

[Prev in Thread] Current Thread [Next in Thread]