[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trouble with lilypond-book on Mac OS X

From: Siska Ádám
Subject: Re: Trouble with lilypond-book on Mac OS X
Date: Tue, 31 Jul 2007 02:49:52 +0200
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-GB; rv: Gecko/20070221 Thunderbird/ Mnenhy/

Graham Percival wrote:
Siska Ádám wrote:
Yes, since that I also created the suggested files, and I added them to a .profile file in the /Users/admin folder (my home folder),

Your user name is admin?  That's unusual.

Well, this is my first Mac (and I switched from Windows not so many time ago), with a pre-installed OS, and since I'm the only one using it, I didn't thought on changing the predefined user name.

but still doesn't work. Is here anybody in the list that owes a Mac and runned these commands successfully?

Yes, me.

The strange is, that the application works fine.

That's not strange at all, since the GUI has nothing to do with the command-line stuff.

If you're not familiar with the command-line, please see some generic information about using the terminal on OSX. If you _are_ familiar with the command-line, please investigate using the normal means: is your PATH set correctly, are the files executable, etc.

Yes, I'm quite unfamiliar with command-line tools, and I never really needed any. For developing, you can use XCode or Eclipse or a lot of other tools, for TeX you can use texmaker or TeXShop quite well, for Lilypond you have the nice (although it would be great if someone added a numerical indicator for the current cursor position because it's quite heavy to debug the source with an editor that doesn't show you where the cursor actually is), there are even good and powerful editors for CSound as well, etc. But I tried to follow the steps in the manual, I created a folder in the /Applications/Lilypond folder (that's where I have the with the file 'lilypond-book' containing the line 'exec /Applications/Lilypond/ "$@"', as indicated in the manual, I runned the 'chmod u+x lilypond-book' command from the recently created bin folder, and I've put a .profile file with the content 'export PATH=$PATH:/Applications/Lilypond/' in my /Users/admin folder, but nothing changed, I get the same error log.

Might you have any idea about what's going on on my machine, taking in consideration these things?

Thank you for your help,

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]