[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

debian control file out of date? was: Re: live cd-with lilypondhttp://li

From: Rob Canning
Subject: debian control file out of date? was: Re: live cd-with lilypond
Date: Mon, 25 Aug 2008 21:54:50 +0100
User-agent: Mozilla-Thunderbird (X11/20080509)

Reinhold Kainhofer wrote:
Hash: SHA1

Am Samstag, 23. August 2008 schrieb Mats Bengtsson:
Rob Canning wrote:
but at the moment we have found that lilypond pulls texlive as a
How come? This used to be true a very long time ago, but there
are no requirements to have a TeX installation to be able to run
LilyPond. See
(for version 2.10) or
nts#Requirements (for version 2.11 and the coming version 2.12) for
on the relevant running requirements.

At least the Debian and Kubuntu packages of lilypond-data have the following requirement:
Pre-Depends: tetex-bin | texlive-base

I suppose that this is not true any longer and was never removed when lilypond switched away from using latex... There is, however, a build-time dependency on metafont (mf-nowin is called to create the feta font), which is in the texlive-base-bin package.
does this mean all this is needed is a modification to the debian controlfile? this would be great as if texlive-base is not a dep then lilypond should be small enough to fit on our live distro :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]