[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fw: Help needed - missing .pdf file after running lilypond sucessful

Subject: Re: Fw: Help needed - missing .pdf file after running lilypond sucessfully.
Date: Fri, 24 Sep 2010 15:15:24 -0700 (PDT)

Hi, neuro:

I think you problem can be resolved. Please refer to vol94 issue 94 message 3 from Phil Holmes. If you are not absolutely need .ps, don't try.  

My problem is after I added as suggested from Phil Holmes, I got the .ps file and I lost .pdf file. I comment out the  line "#(ly:set-option 'delete-intermediate-files #f)" and re-run lilypond, but I lost both .ps and .pdf since. It has been a couple of days.  I have been asking help from lilypond users to resolve. I now wait for help from lily4jedif user.

Lilypond users:
I run Command line lilypond (CMD.EXE) as

c:Documents and Settings\Administrator\Desktop\LILY_POND>lilypond -f --pdf   

and I get the following error message:
GNU LilyPond 2.6.5
error: Incorrect lilypond version: 2.13.32 (2.3.22, 2.6.5)

Can anyone show me how can I set up CMD to run v2.13.33? I uninstall v2.6.5 and install v3.13.33 -  how come I am still running v2.6.5.

Thanks everyone,

From: neuro黃學仁 <address@hidden>
To: MING TSANG <address@hidden>
Cc: address@hidden
Sent: Fri, September 24, 2010 2:09:48 PM
Subject: Re: Fw: Help needed - missing .pdf file after running lilypond sucessfully.

Dear Dr. Tsang

You might want to check out
lilypond --help

Actually, I have met similar, (or more precisely, reverse,) problems
when I run 2.13.33 last month.

It seems, lilypond have output a pdf file, without a ps file as the ps
file was converted to pdf, when I run 2.13.33 last month, as
(The output files shoud be both ps and pdf, in my expectation.)

So, to specifically assign the output to be a ps file, according to the --help,
I run
lilypond -f --ps

So, you might want to run
lilypond -f --pdf
for specifically assign the pdf in your situation.

options are
-f --ps
-f --pdf
-f --png

good luck ^_^

neuro 黃


2010/9/25 MING TSANG <address@hidden>:
> the following reply all did't go thru. Now I try again, just send ti
> lilypond users.
> ----- Forwarded Message ----
> From: MING TSANG <address@hidden>
> To: Kaz Kylheku <address@hidden>
> Cc: address@hidden
> Sent: Fri, September 24, 2010 8:58:11 AM
> Subject: Re: Help needed - missing .pdf file after running lilypond
> sucessfully.
> Kaz,
> thank you. I don't know how to run lilypond on CMD EXE. Can you provide some
> command line script?
> I try the alternative method as suggested. I got the following message:
>  "GS.EXE entry point not found -- the procedure entry point
> address@hidden could not be located in the dynamic link library
> gs-8.70.dll"
> For the past few days I have been rebooting window xp several times.
> Mark Polesky:  thank you for pointing me to contact jedit users. I have send
> them an email and waiting for their response.
> ________________________________
> From: Kaz Kylheku <address@hidden>
> To: MING TSANG <address@hidden>
> Cc: address@hidden
> Sent: Thu, September 23, 2010 11:02:24 PM
> Subject: Re: Help needed - missing .pdf file after running lilypond
> sucessfully.
> This mailing list is about Lilypond.
> What happens if you run just the lilypond executable?
> In windows you can open a CMD.EXE window on the folder and run lilypond on
> the file. If the executable is not in your %PATH%, you will have to use the
> full path.
> Alternately, you should be able, in Explorer, to right click on the .ly file
> and invoke the "Generate PDF" command from the popup menu.
> Be sure that no program has any of the output files (MIDI, PDF, ...) open,
> because this may prevent Lilypond from being able to write to the files.
> (Install a real OS to avoid that problem).
> If you follow this procedure and get a PDF, there is no Lilypond problem.
> Maybe the surrounding tools are "eating" the PDF.
> Also, when was the last time you rebooted that Windows? At least once every
> few days is a good idea.
> On Thu, 23 Sep 2010 15:51:34 -0700 (PDT), MING TSANG <address@hidden>
> wrote:
> Here below is jedit console message display. According to the message a .ps
> file is generated and a .pdf is generated as well.  However I find the .ps
> file but no .pdf file on the folder where the .ly file resides.
> _______________________________________________
> lilypond-user mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]