[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Lynx, colors and VT100

From: Ismael Cordeiro
Subject: Re: lynx-dev Lynx, colors and VT100
Date: Tue, 20 Apr 1999 20:31:12 -0400 (EDT)

On Tue, 20 Apr 1999 address@hidden wrote:

> I think this is an argument that probably is useless, because Ismael still
> doesn't seem to realize that "vt100 emulator" _implies_ that it does not
> emulate things _besides_ a vt100. (That is, it implies strict emulation.)

I do realize that a `"vt100 emulator" _implies_ that it does not emulate
things _besides_ a vt100' but I was not the one who called those terminal
emulators VT100 or VT102. They emulate VT100 and VT102 terminals and give me
more. Like you, I want Lynx in color and the terminal emulation in the
program I use, although called "VT102", support color. Why wouldn't I care
how it's called if I can have Lynx and other programs in colors with it?

> Anyhow, I actually have a question about this color stuff now that there
> has been discussion about it..
> I'm using
> Lynx Version 2.8.1rel.2 (1998)
> I think I'm on Solaris..  (dang I never remember how to check..)

uname -sr

If you're on Solaris it should display "SunOs 5.x".

> In the Options, I can pick different choices for the Show Color popup, but
> it always goes back to OFF no matter what I pick..
> Does this mean it wasn't compiled with Color support in, or what?

If you're actually on Solaris, probably Lynx was compiled with SVR4 curses
and consequently with color support.

> Is there any way this could be improved

Yes, there is...

> so that the other items said <NOT AVAILABLE> or something while I had the
> popup popped up? even if it said something longer like <NOT AVAILABLE
> BECAUSE COLOR NOT COMPILED IN> it would be good.

If you use the "old-style" options menu (FORMS_OPTIONS:FALSE in lynx.cfg),
Lynx will display "Your 'xxx' terminal does not support color" when you try
to set Show Color to ON.

If you don't mind being helped by someone you think that `doesn't seem to
realize that "vt100 emulator" _implies_ that it does not emulate things
_besides_ a vt100', I could probably help you like I helped many Lynx users
with a similar problem.

What terminal or terminal emulation are you using? Does it support color?
What "echo $TERM" says?


       | ISMAEL CORDEIRO            | mailto:address@hidden      |
       | Production sound mixer     | |
       | Montréal - Québec - Canada | |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]