[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: retries not working?

From: Martin Pala
Subject: Re: retries not working?
Date: Tue, 27 Sep 2011 09:57:12 +0200

Hi Nestor,

the retry option was added in Monit 5.3 … if you're using older version, it won't work.

In the Monit 5.3 the retry itself is silent and particular attempt failure doesn't log the error - the error is logged only when all attempts failed (we have extended Monit development version to log the details for every particular attempt in debug mode). It is thus very likely that in your case all 3 consecutive attempts failed since they were too fast (within one cycle) - you can use the cross-cycle failure ratio to wait between retries like this:

    if failed url … for 3 cycles then alert

=> the test will fail only when 3 consecutive cycles ended up with error

Best regards,

On Sep 27, 2011, at 2:28 AM, Nestor Urquiza wrote:


In the rule below:

if (failed url and content == 'login') retry 3 then alert

The retry part seems not working. I am trying to go around a random issue where I am notified the website is not accessible but a minute later I get it is back. In reality the site is never unaccessible.

I have tested this with google, yahoo, cnn and other well known sites. I know for sure there is a problem in our network, perhaps related to a firewall or proxy but I am trying to let us say check the url, wait 2 seconds and retry again before sending the alert. Is that possible?



To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]