[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #31046] Check for lsame obsolete

From: anonymous
Subject: [Octave-bug-tracker] [bug #31046] Check for lsame obsolete
Date: Wed, 15 Sep 2010 19:38:15 +0000
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv: Gecko/20100824 Firefox/3.6.9


                 Summary: Check for lsame obsolete
                 Project: GNU Octave
            Submitted by: None
            Submitted on: Mi 15 Sep 2010 19:38:14 UTC
                Category: Configuration and Build System
                Severity: 3 - Normal
              Item Group: Build Failure
                  Status: None
             Assigned to: None
         Originator Name: Thomas Treichl
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: dev
        Operating System: Mac OS



Dear development team,

  it's been a while since I last tried to compile the latest development
sources but today I gave it another chance. I was surprised that the sources
haven't changed that much since April 2010, so with little modifications I was
able to compile most of the code.

However, I came across the problem that the ./configure script failed because
of a check for lsame which isn't there on my Mac's framework veclib - but I
also wonder if it is still necessary to test for it: I did a quick

  address@hidden ~/Development/Octave$ grep -re "lsame" *
  m4/ax_blas_f77_func.m4:      logical lsame,w
  m4/ax_blas_f77_func.m4:      external lsame
  m4/ax_blas_f77_func.m4:      w = lsame(c1,c2)
  m4/ax_blas_f77_func.m4:      w = lsame(c1,c1)
  m4/ax_blas_f77_func.m4:      ]]),[ax_blas_lsame_fcall_ok=yes],
  m4/ax_blas_f77_func.m4: [ax_blas_lsame_fcall_ok=no])
  m4/ax_blas_f77_func.m4: AC_MSG_RESULT([$ax_blas_lsame_fcall_ok])
  m4/ax_blas_f77_func.m4: if test $ax_blas_lsame_fcall_ok = yes

where I saw that "lsame" exists in the file "ax_blas_f77_func.m4" only. I
removed this test an compilation succeeded up to fltk-backend.cc where I got
my first error.

Is the check for lsame still necessary?

Best regards



Reply to this item at:


  Nachricht geschickt von/durch Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]