[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] KeyError exception

From: Austin Clements
Subject: Re: [rdiff-backup-users] KeyError exception
Date: Sun, 27 Jan 2008 06:51:53 -0500
User-agent: Mutt/1.5.16 (2007-06-11)

I don't know why I didn't think of this before...  I reverted your
patch and tried running the backup again and it worked, suggesting
that your patch fixes the issue when creating a new backup, but breaks
something when trying to increment an existing backup.  However, then
I ran the incremental backup again and it failed with a KeyError, so I
reinstated your patch and it failed with the same KeyError.  Just to
check that the backup itself wasn't wedged, I ran the incremental a
different way that doesn't use both a remote source and a remote
destination and it worked.  So now I'm just completely bamboozled.

Quoth myself on Jan 21 at  5:12 pm:
> Scratch that.  The initial backup task worked, but the next one failed
> with a very similar error involving rorp's, fast processing, and
> KeyErrors.  The destination side raised the following exception:
> *chomp*

Austin Clements                                          MIT/'06/CSAIL
address@hidden                         http://web.mit.edu/~amdragon/
       Somewhere in the dream we call reality you will find me,
              searching for the reality we call dreams.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]