[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Terminal resize problem

From: Sadrul Habib Chowdhury
Subject: Re: Terminal resize problem
Date: Fri, 12 Feb 2010 15:55:39 -0500
User-agent: Mutt/1.5.18 (2008-05-17)

* Ciprian Dorin, Craciun had this to say on [11 Feb 2010, 09:23:42 +0200]:
> On Mon, Feb 8, 2010 at 7:17 AM, J. Bakshi <address@hidden> wrote:
> > On 02/08/2010 10:44 AM, J. Bakshi wrote:
> >> Dear list,
> >>
> >> I have found many discussion in net on the terminal resize issue and I
> >> have tried the solutions as given but no success yet. I am using mrxvt
> >> in my workstation. after logging into the remote box I started screen.
> >> Also set "TERM=xterm" . And now the real problem. If I resize the
> >> terminal; screen still stick with that size when it was called. [ctrl+a
> >> :fit] did not solve the problem. I have also supplied "eval resize" in
> >> .screenrc but no luck. Is there any way to practically fix it ?
> >>
> >> thanks
> >>
> >>
> >
> > BTW: The problem is not there if I don't use hardstatus  and I need
> > hardstatus as I generally open a no. of session
>     Hy there.
>     I have a similar problem with my setup. (I use an
> "auto-maximizing" window manager (i3, and before that ion3), and when
> I open a terminal (rxvt-unicode), with screen in it, 

How do you start rxvt-unicode? How do you create/attach to a session in

> screen thinks
> that the size of the terminal is smaller (80x25?), but after I press
> any key and the program redraws something the correct size is found.
> (This happens only about 33% of the times.)) (I use the latest (or at
> least quite new version) of screen (from ArchLinux).)
>     I've tried to solve this problem myself with commands like resize,
> fit, height, width, etc. No success. The only solution (which I don't
> find satisfying, but annoying) is to put a 'sleep 1' in my screen.rc,
> and I've solved the problem. (But every time I open a console I have
> to stare 1 second at it...)
>     Any feedback to our problems? :)

I haven't been able to reproduce this problem, unfortunately, so no.
Perhaps you could share your .screenrc with us, in case something in
there is triggering the issue?

What version of screen are you guys using? If you could try out the
current development version from git
( and see if the problem
is fixed there, that'd be very great.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]