[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Joel J. Adamson
Subject: AC_PROG_CC_C99 and AC_OPENMP
Date: Wed, 05 May 2010 15:34:55 -0400

Dear Fellow Autoconfers,

I have just tried to build one of my autotools-based projects on a
machine with Autoconf 2.59 [1], and it does not recognize


as you can see here:

/netscr/adamsonj/haploid: Wed May 05> libtoolize 
Remember to add `AC_PROG_LIBTOOL' to `'.[2]
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
/netscr/adamsonj/haploid: Wed May 05> cat /usr/share/aclocal/libtool.m4 >> 
/netscr/adamsonj/haploid: Wed May 05> aclocal
/netscr/adamsonj/haploid: Wed May 05> mkdir m4
/netscr/adamsonj/haploid: Wed May 05> autoreconf -vi
autoreconf: Entering directory `.'
autoreconf: not using Gettext
autoreconf: running: aclocal -I m4 
autoreconf: tracing
autoreconf: not using Libtool
autoreconf: running: /usr/bin/autoconf error: possibly undefined macro: AC_USE_SYSTEM_EXTENSIONS
      If this token and others are legitimate, please use

      See the Autoconf documentation. error: possibly undefined macro: AC_PROG_CC_C99 error: possibly undefined macro: AC_OPENMP
autoreconf: /usr/bin/autoconf failed with exit status: 1
/netscr/adamsonj/haploid: Wed May 05> 

I added a file called "emerald.m4" to the m4 directory containing 

m4_pattern_allow(AC_PROG_CC_C99, AC_OPENMP) 

and autoreconf runs just fine.  However, during the configure stage I
get these errors:

./configure: line 3115: AC_PROG_CC_C99: command not found
./configure: line 19094: AC_OPENMP: command not found 

meaning the macros are not expanded when ./configure is written
(right?).  However, when I compile, I still get the -lgomp flag.

When were these macros added and what's the best solution for me here?



[1]  Local development is with version 2.63

[2]  I remember doing this when I first wrote and it said I
should replace it with LT_INIT which is what I have, but then the older
version complains; I suppose this makes sense.

Joel J. Adamson
Servedio Lab
University of North Carolina at Chapel Hill

FSF Member #8164

Attachment: pgpd7969C5mJr.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]