[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: produce *mod with fortran

From: Eve-Marie Devaliere
Subject: Re: produce *mod with fortran
Date: Tue, 01 Feb 2011 15:37:04 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20101207 Thunderbird/3.1.7

oops I think I spoke a little too fast..... autoconf was not giving me
errors anymore but configure is still not happy....

first of all even with my
AC_CONFIG_MACRO_DIR([m4]) in (before macro calls)
and ACLOCAL_AMFLAGS= -I m4 in (top one) , I still need to run 
aclocal with the '-I m4' else it doesn't recognize 
AX_F90_MODULE_EXTENSION and AX_F90_MODULE_FLAG in my m4 folder... 

Then, I still get
./configure: line 3206: -I: command not found  
checking fortran 90 modules inclusion flag... -I
checking fortran 90 modules extension... mod
./configure: line 4716: syntax error near unexpected token `('
./configure: line 4716: `  $as_echo_n "(cached) " >&6'

The lines in my that I am guessing are raising the error are
if test "x$ax_f90_modext" != xunknown; then
  FC_MODEXT=$ax_f90_modext# isn't it the same??

I am confused because the if and else seem to do the same
action.... If I get rid of the above section of the file
configure runs fine...

in configure the snippet that crashes is:
if ${ac_cv_prog_DUMPBIN+:} false; then :
  $as_echo_n "(cached) " >&6
  if test -n "$DUMPBIN"; then
  ac_cv_prog_DUMPBIN="$DUMPBIN" #

Would anybody have an idea on what is going on?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]