[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems executing ./configure on Solaris

From: Lorrie Wood
Subject: Re: Problems executing ./configure on Solaris
Date: Wed, 23 Oct 2002 11:54:20 -0700
User-agent: Mutt/1.2.5i

On Wed, Oct 23, 2002 at 11:26:15AM -0700, Lorrie Wood wrote:
>       Hello, I'm having trouble using scripts generated by autoconf
> on Solaris 8. No matter what package is involved (I've tried mutt,
> ncurses, and slocate so far), the ./configure process hangs when attempting
> to create config.status. It was suggested to me that I try changing all
> instances of /bin/sh to one of the existing bash instances on my
> system, but this did not fix anything. Trussing the process shows it has
> gone to sleep, config.log shows nothing out of the ordinary -- there just
> aren't any error messages to be found!

        root's default shell had been changed to bash (a dynamically
linked bash! I could scream -- not because it's bash, but because it's
not static, but I digress), and exporting CONFIG_SHELL of bash before
running ./configure made it go. This seems strange to me, as I seem to
recall running ./configure scripts on plain sh earlier without trouble.
The server is due for a rebuild (for a myriad of reasons), but my main
problem is 'solved.'

-- Lorrie

reply via email to

[Prev in Thread] Current Thread [Next in Thread]