[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] ATmega8 & avr-libc

From: Raphael Assenat
Subject: Re: [avr-gcc-list] ATmega8 & avr-libc
Date: Mon, 8 Sep 2003 10:01:12 -0400

I have exactly the same problem. I found a quick workaround is to copy the 
file crtm8.o from $(PREFIX)/lib/avr4/crtm8.o to the working directory. Since 
then, my application links correctly.


On Monday 08 September 2003 09:37 am, you wrote:
> Hi,
> i am not shure, if I am right here, or if this post is OT.
> recently I developed successfull with S4433 and S8515. Now I tried to
> develop for a ATmega8(L).
> But I am getting an errormessage:
> bash-2.05b# make
> /usr/local/atmel/bin/avr-gcc -g -mmcu=atmega8 -Wall -Wstrict-prototypes
> -Os -mcall-prologues -o avrledtest.out -Wl,-Map,avrledtest.map
> avrledtest.o -lm
> /usr/local/atmel/lib/gcc-lib/avr/3.3.1/../../../../avr/bin/ld: cannot
> open crtm8.o: No such file or directory
> make: *** [avrledtest.out] Error 1
> bash-2.05b#
> It seems, that my installation does not feature atmega8. I have poked a
> little with configure, but did not managed to enable atmega8 support. It
> should be something with tat multisubdir.
> I have used avr-libc-20020203.
> Which version of the avr-libc should I use? A CVS-Snapshot (I've tried
> this, but there were different?
> Regards
> Leonard Penzer
> _______________________________________________
> avr-gcc-list mailing list
> address@hidden
> http://www.avr1.org/mailman/listinfo/avr-gcc-list

Raphael Assenat
Tout est possible sauf l'impossible.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]