[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] problems on linux

From: Kitts
Subject: [avr-gcc-list] problems on linux
Date: Tue, 31 May 2005 22:52:29 +0530
User-agent: KMail/1.8

Hi All,

Does anybody here use FreeRTOS with the AVR?

Well! With FreeRTOS, i tried running the demo application making 
suitable modifications for use with the atmega16 but it was unable to 
handle the number of tasks. I then reduced the tasks and it worked 

I did all of the compilation and programming on linux and avrdude with 
the stk500v2 protocol. I put up the issue with the number of tasks on 
the FreeRTOS forum and to my surprise, others on the forum were able to 
run the demo as is with all of the tasks executing!

I then tried compiling for the mega128 and nothing would work! I then 
thought i needed to debug on a simulator and discovered that "make 
coff" or "make extcoff" returned errors. Now the interesting part is 
that all of what i tried work fine when using Winavr on windows.

Does anybody have a clue of what could be the problem? I seek your 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]