[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] problems on linux

From: E. Weddington
Subject: Re: [avr-gcc-list] problems on linux
Date: Tue, 31 May 2005 11:37:25 -0600
User-agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)

Kitts wrote:

Hi All,

Does anybody here use FreeRTOS with the AVR?

Well! With FreeRTOS, i tried running the demo application making suitable modifications for use with the atmega16 but it was unable to handle the number of tasks. I then reduced the tasks and it worked fine.

I did all of the compilation and programming on linux and avrdude with the stk500v2 protocol. I put up the issue with the number of tasks on the FreeRTOS forum and to my surprise, others on the forum were able to run the demo as is with all of the tasks executing!
On Linux? Or on Windows?

I then tried compiling for the mega128 and nothing would work! I then thought i needed to debug on a simulator and discovered that "make coff" or "make extcoff" returned errors. Now the interesting part is that all of what i tried work fine when using Winavr on windows.
The ELF to COFF convertor is only available on WinAVR as it is only used by Atmel's AVR Studio which is a Windows-only program. For debugging on Linux, use GDB + simulavr.

Does anybody have a clue of what could be the problem? I seek your advice!

Not offhand. Probably the FreeRTOS folks would have to take a look at what's going on. Also, are you making sure that the version of AVR GCC (and other programs) are the same on Linux and Windows?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]