[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] Help! gcc 4.1.1, dwarf-2 and Atmel USB parts

From: Rick Mann
Subject: [avr-gcc-list] Help! gcc 4.1.1, dwarf-2 and Atmel USB parts
Date: Fri, 15 Dec 2006 14:33:01 -0800

Sorry for the long preamble. You can skip to the real question below...

I'm trying to build one of Atmel's USB samples (the generic HID device) that targets the at90usb1287. According to the documentation, it works with WinAVR 20060421, so at first I thought it would work with my avr-gcc-4.0.3 installation. I got errors that made me think 4.0.3 didn't have support for the at90usb parts, so I got the latest 4.1.1. That also didn't work (same error), so I look in the archives and found other people asking about patches. I also tried to find info on the WinAVR site about what patches his April release included, but no luck. Finally I Googled for "avr-gcc patches" and found the gcc-patch email archives. Searching for "at90usb" turned up the following email:


But I'm pretty sure that's for 4.2. I checked out 4.2 from subversion (is there a better way to get it?), but haven't yet tried to build it. A follow-on email says the patch was applied, so hopefully that's already in the 4.2 branch.

So I used that patch as a guide hand-patch my 4.1.1. I did that, and tried to build the Atmel example, and I get this:

$ make
avr-gcc -I"./.." -I"../conf" -I"../../../../at90usb128" - I"../../../../common" -mmcu=at90usb1287 -D AVRGCC -Wall -gdwarf-2 - Os -fsigned-char -MD -MP -MT usb_specific_request.o -MF dep/ usb_specific_request.o.d -c ../usb_specific_request.c ../usb_specific_request.c:1: error: target system does not support the "dwarf-2" debug format

I think it's the same error I always got, but looking more closely, I see it's complaining about "dwarf-2". So, the real question is: what's going on? Did I fail to include dwarf-2 support when I built gcc (I disabled libssp, dunno what that was). Does 4.1.1 actually already support the usb parts but not dwarf on them?

Why is WinAVR able to build this example?

Thanks so much for any help. I really want to get started on this USB project, and I hate to have to resort to using Windoze or even a different chip.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]