[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] TeXmacs / AXIOM under SuSE 8.0

From: Bertfried Fauser
Subject: [Axiom-developer] TeXmacs / AXIOM under SuSE 8.0
Date: Sun, 9 Nov 2003 12:47:25 +0100 (CET)

Dear Bill,

as I promised, I will keep you informed about my quest to run AXIOM inside
of TeXmacs. I would not yet call it nightmare, sicne it kept me from
sleeping last nights...

* FYI: I had installed the RedHat prpm of TeXmacs (a practice which worked
for many other HedHat packages on my SuSE distribution with variouse
versions) For the reasons you know already (missing path varibales, etc
this didn't work.

* Now I downloaded TeXmacs sources and tried to compile...
  -- The compilation failed to to a missing guile package
  -- I downloaded guile and ./configured, make, make install
     worked, hence I think guile has been installed successfully.
     I was able to start it, but don't know what to do with it.
  -- I did a seciond run on TeXmacs and it compiled without further
  -- I made sure that axiom and AXIOMsys is in the path
  -- I copied tm_axiom 1.0.3 as distributed from the savannah AXIOM
     web-site and copied it to the correct places(while the RedHat rpm put
     TeXmacs in the dirs /usr/share/TeXmacs and /usr/libexec/TeXmacs the
     compiles version resides in /usr/local/share/TeXmacs and
    /usr/local/libexec/ which should be no problem.

  -- to have a reverence, I renamed my maple8 (vioa a link) into maple, so
     that the command maple launches a maple8 command line session.

* My Findings:
  -- It is impossible (for me) to detect from inside TeXmacs which version
     is running, the rpm is while the self compiles is
     This is annoying and there should be  a possibility to get this inforation
     in the menue Help->About
  -- After starting (the compiled) TeXmacs, I do no longer find in the
     Text->Session menue the session called Shell, thats quite awkward,
     since a shell is always in the path?
  -- TeXmacs started a scheme session and I could type something after the
     prompt, and TeXmacs came up with some scheme output (since I do not
     know scheme, I produced an error message, but it looks quite
  -- TeXmacs was able to strt a maple (veriosn8) session, I see the
     Maple leave stratuup message, but then a red written error message
     and further input to maple was no possible.
  -- TeXmacs is still not able to start an AXIOM session, the console says
     that tm_axiom is loaded (i.e that from savannah AXIOM) but nothing
     happens, beside that a blue session box is created. Typing in this
     box is possible but nothing happens after pressing <return>, I get
     just a new line.
     If I goto the Session menue and press close session, I get an axiom
     promt 'axiom]' but there is no further typing possible.

All in all I spent now several hours to check pathes, to move the files to
the correct place, compile guile, TeXmacs etc but didn't succed in making
TeXmacs even functional with maple (version8) (I didn't check with maple
5,6,7,9, since maple 8 might be still the most common in use and should
wotk without problems)

Given the variouse maple versions, it might be a good habit of TeXmacs to
provide tm_maple(version) files if tehre is a need to have different such
interfaces, the same may go for axiom, tm_axiom.gnu1 tm_axiom.NAG etc

I would really like to hear if other have succeded to work with TeXmacs
under SuSe, say with maple, maxima, and of course with AXIOM!

I will ponder further on what I might have done wrong and then give it
another chance. For the moment I ran out of further ideas ....


% |   | PD Dr Bertfried Fauser    Fachbereich Physik    Fach M 678  |
%  \ /  Universit"at Konstanz     78457 Konstanz        Germany     |
% (mul) Phone : +49 7531 693491   FAX : +49 7531 88-4864 or 4266 (comul)
%   |   E-mail: address@hidden                   / \
%   |   URL   :    |   |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]