[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: A bash bug? sh_malloc missing

From: Chet Ramey
Subject: Re: A bash bug? sh_malloc missing
Date: Tue, 2 Feb 2021 09:11:37 -0500
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:78.0) Gecko/20100101 Thunderbird/78.6.1

On 2/1/21 5:29 PM, George R Goffe wrote:

I just checked out the "latest" bash from the repo at savanna.gnu.org and am 
having build problems.

I have tried --with-gnu-malloc and it's alias and also tried building without 
any malloc parameters in configure without success. Enclosed below is what I'm 
seeing. I have a full build log available if needed.

This looks like you got part of the build compiled with BASH_MALLOC and
part without.

If you compile with the bash malloc enabled, you'll get references to
bash_malloc, but then you need to link with the bash malloc library in

I'm surprised that you somehow got sh_malloc references in gen-helpfiles,
since that file explicitly undefines all of the names that would get you
using the bash malloc.

My advice is to run `make distclean' and start from scratch with the default build options, then go from there. Your system can't be *that*
much of an oddball.


``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, UTech, CWRU    chet@case.edu    http://tiswww.cwru.edu/~chet/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]