bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RMAIL doesn't always recognize rmail-mime-charset-pattern


From: David Kuehling
Subject: Re: RMAIL doesn't always recognize rmail-mime-charset-pattern
Date: 19 May 2002 17:24:25 +0200

>>>>> "Eli" == Eli Zaretskii <address@hidden> writes:

> This probably means that the culprit is something related to process
> I/O, not file I/O.  Do you read your pop3-fetched mail by receiving
> output of some process, or does that process create a file which you
> then direct RMAIL to read?

I use the standard pop3 mail facility of emacs; using a "po:username"
mailbox in `rmail-primary-inbox-list' (and the environment variable
MAILHOST specifying the mail server's name).

I had a closer look on how emacs pop3 mail retrieval works.  It uses the
movemail program for copying the remote mailbox into a local temporary
file and then gets mail from that file as it would do with a local
inbox.  So I used the movemail program for manually moving the mail.
The resulting file, mailbox-popretrieved (attached), shows a few small
differences from the orignal mailbox.  There are some additional lines
and flags added to the mails.

That mail, read using C-u g mailbox-popretrieved <Ret>, now triggers the
bug, ie EUC-JP is not correctly decoded.  Is this due to the minor
differences?  Hopefully you can reproduce the bug (else it might already
be fixed with your version... I'm running 21.1.1).

David K├╝hling
-- 
GnuPG public key: http://user.cs.tu-berlin.de/~dvdkhlng/dk.gpg
Fingerprint: B17A DC95 D293 657B 4205  D016 7DEF 5323 C174 7D40

Attachment: mailbox-popretrieved.gz
Description: Binary data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]