bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

No graceful exit if .emacs-places cannot be written?


From: wfc
Subject: No graceful exit if .emacs-places cannot be written?
Date: Wed, 21 Jun 2006 15:11:23 -0400

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.3.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2005-02-04 on porky.build.redhat.com
configured using `configure  --build=i386-redhat-linux --host=i386-redhat-linux 
--target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr 
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc 
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib 
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com 
--mandir=/usr/share/man --infodir=/usr/share/info --with-pop --with-sound'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: C
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

I sudo'd to be another user ('X'), however $HOME was still
defined to by my own directory.  I then edited a file owned by X
and tried exiting Emacs with C-x C-c.  AFter saying yes to save
the file in question, the next prompt was:

    File .emacs-places is write-protected; try to save anyway? (yes or no)

I understood what was happening, so I said 'no' figuring that it
simply would skip trying to update my places file.  The response,
however was:

    Attempt to save to a file which you aren't allowed to write

Hmmmm.   So I tried C-x C-c again.  This time the response was:

    Save file /home/wfc/.emacs-places? (y, n, !, ., q, C-r or C-h)

Answered no.

    Modified buffers exist; exit anyway? (yes or no)

Answered yes.

    File .emacs-places is write-protected; try to save anyway? (yes or no)

Answered yes -- and we're right back where we started from.  I've
also tried answering yes to the 'try to save anyway' which of
course didn't work.  For the record, my .emacs-places file
permissions are:

    -rw-r--r--  1 yyy zzz 1751 Jun 21 13:56 /home/yyy/.emacs-places

I hope it's clear that I did not expect Emacs to maintain my places file, only 
that it should have given me a graceful way out.  As it was I had to suspend 
the process and then kill -9 it.


Recent input:
C-h C-p ESC x r e p o r t - e m a c s - b u g RET

Recent messages:
Loading regexp-opt...done
END  <-- ~wfc/.emacs
Loading jka-compr...done
For information about the GNU Project and its goals, type C-h C-p.
Loading sendmail...done
Note: file is write protected
Loading places from ~/.emacs-places...
Loading places from /home/wfc/.emacs-places...done
Loading emacsbug...done
call-interactively: Text is read-only




reply via email to

[Prev in Thread] Current Thread [Next in Thread]