bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#10398: [PATCH] Use real vfork under Cygwin: it's fine these days


From: Eli Zaretskii
Subject: bug#10398: [PATCH] Use real vfork under Cygwin: it's fine these days
Date: Wed, 11 Apr 2012 22:26:58 +0300

> Date: Wed, 11 Apr 2012 08:35:02 -0400
> From: Ken Brown <address@hidden>
> CC: address@hidden, address@hidden, address@hidden,
>         address@hidden
> 
> >> I don't think we should make an effort to support Cygwin versions
> >> earlier than 1.7.  Cygwin 1.5 is no longer supported by Cygwin, so I
> >> don't see a reason for emacs to try to support it.  I suspect there
> >> have been many emacs changes that are not compatible with Cygwin
> >> 1.5.
> >
> > Fair enough, but then perhaps the configure script should at least
> > warn, or maybe even refuse to continue, if it sees an older version?
> 
> A warning would be fine, but I would suggest waiting until someone 
> reports an actual problem.  My guess is that no one running Cygwin 1.5 
> will ever try to build the emacs trunk.  But if someone does try and 
> runs into problems, we can take the appropriate action.  If you 
> disagree, I have no objection to inserting a warning now.

I think we should put our money where our mouth is.  If we consider
Cygwin 1.5 unsupported, we should at least warn the prospective users
that they are building Emacs with unsupported tools.

So yes, I think we should insert a warning now.  Could you please make
such a change?  TIA.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]