bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#19349: 25.0.50; Can not use package manager after emacs upgrade. Iss


From: Charles Magid
Subject: bug#19349: 25.0.50; Can not use package manager after emacs upgrade. Issue may not be in package.e
Date: Thu, 11 Dec 2014 12:26:58 -0500

Could not send email via M-x report-emacs-bug.  Possibly part of same issue

From: address@hidden
To: address@hidden
Subject: 25.0.50; Can not use package manager after emacs upgrade. Issue may not be in package.el.
Date: Thu, 11 Dec 2014 12:22:54 -0500
Message-ID: <address@hidden>
--text follows this line--


Can not install any packages.

I would like to follow the bug reporting instructions 'emacs -Q' I am
no longer sure I can. 

Re: Emacs is launched on my behalf by the commands the homebrew recipe
printed out.

2014-12-10 22:37:32 brew uninstall --force emacs
2014-12-10 22:37:40 brew install emacs --cocoa --use-git-head --HEAD
2014-12-10 22:47:31 ln -sfv /Users/cmagid/brew/opt/emacs/*.plist ~/Library/LaunchAgents
2014-12-10 22:47:43 launchctl load ~/Library/LaunchAgents/homebrew.mxcl.emacs.plist

New emacs install getting error url-http-parse-headers when starting elpa.

(package-list-packages nil) ;;  # => Command hung. I had to quit out.  After I tried stuff it loads but can not install packages

;; Buffer *Messages*  
;; # =>
  ;; Contacting host: elpa.gnu.org:80
  ;; error in process filter: url-http-parse-headers: Symbol's function definition is void: gnutls-available-p
  ;; error in process filter: Symbol's function definition is void: gnutls-available-p
  ;; Quit

(emacs-version nil)
;; # => "GNU Emacs 25.0.50.1
  ;; (x86_64-apple-darwin11.4.2, NS appkit-1138.51 Version 10.7.5 (Build 11G63b))
  ;; of 2014-12-10 on rmbp15-2012-00.ad.corp.lan.home"

(toggle-debug-on-error 1)
(package-list-packages nil)
;; # => Debugger entered--Lisp error: (void-function gnutls-available-p)
  ;;  gnutls-available-p()
  ;;  url-http-parse-headers()
  ;;  url-http-content-length-after-change-function(14470 16470 2000)
  ;;  url-http-generic-filter(#<process elpa.gnu.org> "https://github.com/m00natic/vlfi\"))])\n (w3 .\n     [(4 0 49)\n      nil \"Fully customizable, largely undocumented web browser for Emacs\" tar\n      ((:keywords \"faces\" \"help\" \"comm\" \"news\" \"mail\" \"processes\" \"mouse\" \"hypermedia\")\n       (:url . \"http://elpa.gnu.org/packages/w3.html\"))])\n (wcheck-mode .\n      [(2014 6 21)\n       nil \"General interface for text checkers\" single\n       ((:url . \"https://github.com/tlikonen/wcheck-mode\")\n (:keywords \"text\" \"spell\" \"check\" \"languages\" \"ispell\"))])\n (web-server .\n     [(0 1 1)\n      ((emacs\n (24 3)))\n      \"Emacs Web Server\" tar\n      ((:keywords \"http\" \"server\" \"network\")\n       (:url . \"https://github.com/eschulte/emacs-web-server\"))])\n (websocket .\n    [(1 3)\n     nil \"Emacs WebSocket client and server\" tar\n     ((:keywords \"communication\" \"websocket\" \"server\")\n      (:url . \"http://elpa.gnu.org/packages/websocket.html\"))])\n (windresize .\n     [(0 1)\n      nil \"Resize windows interactively\" single\n      ((:url . \"http://elpa.gnu.org/packages/windresize.html\")\n       (:keywords \"window\"))])\n (wisi .\n       [(1 1 0)\n ((cl-lib\n  (0 4))\n (emacs\n  (24 2)))\n \"Utilities for implementing an indentation/navigation engine using a generalized LALR parser\" tar\n ((:keywords \"parser\" \"indentation\" \"navigation\")\n (:url . \"http://stephe-leake.org/emacs/ada-mode/emacs-ada-mode.html\"))])\n (wpuzzle .\n  [(1 1)\n   nil \"find as many word in a given time\" single\n   ((:url . \"http://elpa.gnu.org/packages/wpuzzle.html\")\n    (:keywords))])\n (xclip .\n [(1 3)\n nil \"use xclip to copy&paste\" single\n ((:url . \"http://elpa.gnu.org/packages/xclip.html\")\n  (:keywords \"convenience\" \"tools\"))])\n (xpm .\n      [(1 0 3)\n       nil \"edit XPM images\" tar\n       ((:keywords \"multimedia\" \"xpm\")\n (:url . \"http://www.gnuvola.org/software/xpm/\"))])\n (yasnippet .\n    [(0 8 0)\n     nil \"Yet another snippet extension for Emacs.\" tar\n     ((:keywords \"convenience\" \"emulation\")\n      (:url . \"http://github.com/capitaomorte/yasnippet\"))]))\n")
  ;;  accept-process-output(#<process elpa.gnu.org>)
  ;;  url-retrieve-synchronously("http://elpa.gnu.org/packages/archive-contents")
  ;;  url-insert-file-contents("http://elpa.gnu.org/packages/archive-contents")
  ;;  package--download-one-archive(("gnu" . "http://elpa.gnu.org/packages/") "archive-contents")
  ;;  package-refresh-contents()
  ;;  package-list-packages(nil)
  ;;  funcall-interactively(package-list-packages nil)
  ;;  call-interactively(package-list-packages record nil)
  ;;  command-execute(package-list-packages record)
  ;;  execute-extended-command(nil "package-list-packages" "package-li")
  ;;  funcall-interactively(execute-extended-command nil "package-list-packages" "package-li")
  ;;  call-interactively(execute-extended-command nil nil)
  ;;  command-execute(execute-extended-command)

I did not have this problem yesterday but thenn I decided to update emacs. I did the following to install emacs: (just like I did the last 5+ times I installed it. Using instructions from http://viget.com/extend/emacs-24-rails-development-environment-from-scratch-to-productive-in-5-minu)

  $ brew uninstall emacs
  $ brew install emacs --cocoa --use-git-head --HEAD

System Software Overview:

  System Version: Mac OS X 10.7.5 (11G63b)
  Kernel Version: Darwin 11.4.2
  Boot Volume: Macintosh HD
  Boot Mode: Normal
  Computer Name: rmbp15-2012-00.ad.corp.lan
  User Name: Charles Magid (cmagid)
  Secure Virtual Memory: Enabled
  64-bit Kernel and Extensions: Yes
  Time since boot: 50 minutes

I found http://www.gnu.org/software/emacs/manual/html_mono/emacs-gnutls.html section 2 (but I could not understand how to make use of the information)

(describe-variable (quote gnutls-log-level))
;; # => 
;;    "gnutls-log-level is void as a variable.

;;    Documentation:
;;    Not documented as a variable."  

(describe-function (quote gnutls-available-p))
;; # => 
;;    gnutls-available-p is an alias for `gnutls-available-p',
;;    which is not defined.  Please make a bug report.

;;    [back]


I tried various things like setting the gnutls-log-level and brew installing GnuTLS.
Elpa lists the packages now but I see the following in *Messages* buffer. So I don't think it works
;; # => 
;;     url-http-parse-headers: Symbol's function definition is void: gnutls-available-p
;;     Quit
;;     Contacting host: elpa.gnu.org:80
;;     Failed to download `gnu' archive.
;;     Failed to download `melpa' archive.
;;     Failed to download `marmalade' archive.
;;     Failed to download `ELPA' archive.
;;     Failed to download `SC' archive.




In GNU Emacs 25.0.50.1 (x86_64-apple-darwin11.4.2, NS appkit-1138.51 Version 10.7.5 (Build 11G63b))
 of 2014-12-10 on rmbp15-2012-00.ad.corp.lan.home
Windowing system distributor `Apple', version 10.3.1138
Configured using:
 `configure --prefix=/Users/cmagid/brew/Cellar/emacs/HEAD
 --enable-locallisppath=/Users/cmagid/brew/share/emacs/site-lisp
 --infodir=/Users/cmagid/brew/Cellar/emacs/HEAD/share/info/emacs
 --without-dbus --without-gnutls --with-ns --disable-ns-self-contained'

Configured features:
ACL LIBXML2 ZLIB

Important settings:
  locale-coding-system: nil

Major mode: Org

Minor modes in effect:
  csv-field-index-mode: t
  diff-auto-refine-mode: t
  yas-global-mode: t
  yas-minor-mode: t
  wrap-region-global-mode: t
  wrap-region-mode: t
  shell-dirtrack-mode: t
  desktop-save-mode: t
  textmate-mode: t
  show-paren-mode: t
  delete-selection-mode: t
  global-eldoc-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  column-number-mode: t
  line-number-mode: t

Recent messages:
Mark set
C-x C-g is undefined
Mark set
Saved text from "
Can not use package manager after emacs"
Making completion list...
Do you want to submit a report on CC Mode? (y or n) n
Saving file /Users/cmagid/projects/local-data/organize/gtd.org...
Wrote /Users/cmagid/projects/local-data/organize/gtd.org
Making completion list...

Load-path shadows:
/Users/cmagid/.emacs.d/el-get/loc-changes/loc-changes hides /Users/cmagid/.emacs.d/elpa/loc-changes-20130723.1930/loc-changes
/Users/cmagid/.emacs.d/el-get/load-relative/load-relative hides /Users/cmagid/.emacs.d/elpa/load-relative-20141115.1930/load-relative
~/.emacs.d/el-get/el-get-install hides /Users/cmagid/.emacs.d/elpa/load-relative-20141115.1930/el-get-install
/Users/cmagid/.emacs.d/el-get/test-simple/test-simple hides /Users/cmagid/.emacs.d/elpa/test-simple-20140326.1848/test-simple

Features:
(shadow mail-extr emacsbug message rfc822 mml mml-sec mm-decode
mm-bodies mm-encode mailabbrev gmm-utils mailheader sendmail reporter
dabbrev eieio-opt speedbar sb-image ezimage dframe pcmpl-unix picture
debug misearch multi-isearch apropos mail-utils network-stream nsm
starttls url-http tls mail-parse rfc2231 rfc2047 rfc2045 ietf-drums
url-gw url-cache url-auth url url-proxy url-privacy url-expand
url-methods url-history url-cookie url-domsuf url-util mailcap
url-handlers url-parse auth-source eieio eieio-core mm-util mail-prsvr
password-cache url-vars finder-inf mule-util haml-mode css-mode dcl-mode
tempo checkdoc disp-table whitespace markdown-mode js json cc-mode
cc-fonts cc-guess cc-menus cc-cmds cc-styles cc-align cc-engine cc-vars
cc-defs rubocop conf-mode csv-mode sort yaml-mode sh-script executable
autorevert filenotify org-element org-rmail org-mhe org-irc org-info
org-gnus gnus-util org-docview doc-view image-mode org-bibtex bibtex
org-bbdb org-w3m org org-macro org-footnote org-pcomplete org-list
org-faces org-entities noutline outline org-version ob-emacs-lisp ob
ob-tangle ob-ref ob-lob ob-table ob-exp org-src ob-keys ob-comint
ob-core ob-eval org-compat org-macs org-loaddefs format-spec find-func
cal-menu calendar cal-loaddefs rinari jump inflections findr
ruby-compilation which-func jka-compr linum vc-git diff-mode inf-ruby
thingatpt rspec-mode byte-opt flymake compile auto-complete popup
yafolding ruby-mode smie ls-lisp yasnippet webjump browse-url
wrap-region dash rainbow-mode easy-mmode color markerpen shell pcomplete
comint ansi-color ring todotxt ido desktop frameset server cus-edit
cus-start cus-load textmate imenu iedit rect .loaddefs el-get
el-get-autoloads el-get-list-packages el-get-dependencies el-get-build
el-get-status pp el-get-methods el-get-fossil el-get-svn el-get-pacman
el-get-github-zip el-get-github-tar el-get-http-zip el-get-http-tar
el-get-hg el-get-go el-get-git-svn el-get-fink el-get-emacswiki
el-get-http el-get-notify help-mode el-get-emacsmirror el-get-github
el-get-git el-get-elpa el-get-darcs el-get-cvs el-get-bzr el-get-brew
el-get-builtin el-get-apt-get el-get-recipes derived el-get-byte-compile
el-get-custom el-get-core autoload lisp-mnt bytecomp byte-compile
cl-extra cconv dired tango-dark-theme paren time-date delsel
evernote-mode tree-widget wid-edit info easymenu cl-macs cl gv advice
help-fns edmacro kmacro cl-loaddefs cl-lib package epg-config tooltip
eldoc electric uniquify ediff-hook vc-hooks lisp-float-type mwheel
ns-win tool-bar dnd fontset image regexp-opt fringe tabulated-list
newcomment elisp-mode lisp-mode prog-mode register page menu-bar
rfn-eshadow timer select scroll-bar mouse jit-lock font-lock syntax
facemenu font-core frame cham georgian utf-8-lang misc-lang vietnamese
tibetan thai tai-viet lao korean japanese hebrew greek romanian slovak
czech european ethiopic indian cyrillic chinese case-table epa-hook
jka-cmpr-hook help simple abbrev minibuffer nadvice loaddefs button
faces cus-face macroexp files text-properties overlay sha1 md5 base64
format env code-pages mule custom widget hashtable-print-readable
backquote make-network-process cocoa ns multi-tty emacs)

Memory information:
((conses 16 1103245 93840)
 (symbols 48 43599 0)
 (miscs 40 2238 1435)
 (strings 32 148376 32230)
 (string-bytes 1 4038764)
 (vectors 16 55164)
 (vector-slots 8 1751186 148494)
 (floats 8 1074 596)
 (intervals 56 119649 5315)
 (buffers 976 275))


--
Best,
::Charles

reply via email to

[Prev in Thread] Current Thread [Next in Thread]