bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#22054: Potential errors in package--builtins


From: Jonas Bernoulli
Subject: bug#22054: Potential errors in package--builtins
Date: Thu, 03 Dec 2015 15:46:54 +0100
User-agent: mu4e 0.9.15; emacs 25.0.50.1

Artur Malabarba <address@hidden> writes:

> 2015-11-29 19:24 GMT+00:00 Jonas Bernoulli <address@hidden>:
>> * `ielm' is missing from the list.  I suspect it is not detected as a
>>   package because the first line does not contain the summary.
>
> No. It needs a version number to be considered a package. But then,
> why should it be on the list? Is it also provided in one of the
> archives?

Why not?  It is a self-contained package, just like many other
self-contained packages, which are listed as individual packages.  I
cannot see a reason why these other packages should be treated as such,
but not this one.

There are other libraries which one might argue should, or should not,
be considered to be individual packages, but in this case it seems
pretty clear to me that it should be a package, because many other
libraries "just like it" are.

>> * `cl-preload' is listed as a separate package.
>>
>> * `eieio-compat' is listed as a separate package.  But I suspect that
>>   is intentional.  Not sure though.
>>
>> * `sasl-scram-rfc' is listed as a separate package, but all the other
>>   `sasl-*' libraries are part of the `sasl' package.
>
> Assuming you mean cl-preloadED.el...

Yes.

> Maybe someone just fixed it but none of these are listed as built-ins
> for me.

On the `emacs-25' branch, they all have an individual entry in
`package--builtins'.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]