bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31457: 27.0.50; Move starttls.el and tls.el to lisp/obsolete/


From: Noam Postavsky
Subject: bug#31457: 27.0.50; Move starttls.el and tls.el to lisp/obsolete/
Date: Tue, 15 May 2018 20:51:51 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Eli Zaretskii <address@hidden> writes:

>> From: Robert Pluim <address@hidden>
>> Date: Tue, 15 May 2018 15:27:42 +0200
>> Cc: address@hidden
>> 
>> Cool. Do we want to remove sslv3 support from tls.el as well, or are
>> we not making any more changes to it now?
>
> I see no need to remove anything from a package that becomes obsolete.

The sslv3 "support" is just the "gnutls-cli --x509cafile %t -p %p %h
--protocols ssl3" entry in the default value for tls-program, right?  I
think removing it wouldn't really be removing the feature as such, just
making the default "safer".  People who know what they are doing can
still customize with the appropriate value to get sslv3 if they want.

Hmm, and it looks like my version of gnutls-cli (3.5.8) doesn't even
support the --protocols switch anyway.

"Basil L. Contovounesios" <address@hidden> writes:
>>  
>> +** The tls.el and starttls.el libraries are now marked obsolete.
>> +Use of builtin of function based on libgnutls is recommended instead.
>                  ^^^^
>
> Typo?

Oops.  Not sure what I was actually aiming for there.  I rewrote like
this:

** The tls.el and starttls.el libraries are now marked obsolete.
Use of builtin libgnutls based functionality (described in the Emacs
GnuTLS manual) is recommended instead.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]