[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PSPP-BUG: [patch #5236] Case Data type

From: Ben Pfaff
Subject: PSPP-BUG: [patch #5236] Case Data type
Date: Wed, 12 Jul 2006 22:44:22 -0700
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20060406 Firefox/ (Debian-1.5.dfsg+

Follow-up Comment #1, patch #5236 (project pspp):

So, I basically like the idea.  But:

* "datum" is a bad name IMO.  It's too generic.  "value" is bad enough. 
Maybe "string_data" or "char_data" or "value_byte" or "value_octet" or... 
Actually I don't like any of those either.  The name should ideally indicate
that it's related to what goes in a "union value" and that it's 8 bits in
size and it's opaque.  Anyone got any ideas?

* I think that its definition should be in value.h, because it's intimately
related to what goes in a "union value".  But I'm willing to be persuaded
otherwise--do you have an argument why it should be in a new header of its


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]