[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with MacOs installation latest version

From: Giulia Golini
Subject: Re: problem with MacOs installation latest version
Date: Thu, 27 Oct 2022 12:41:02 +0100

Hi Mohammad,
So, I have tried to uninstall Ghostscript, I updated it with brew but after running again "make check" I got the same error.
I fixed the problem, after installing again Ghostscript with:

brew link --overwrite ghostscript

So it was just not linked.

I have no errors now when I install the new version of GNuastro and astrometry.net is also working.



Il giorno gio 27 ott 2022 alle ore 10:44 Mohammad Akhlaghi <mohammad@akhlaghi.org> ha scritto:
Thanks Giulia,

In the P.S. we see the error message in 'tests/test-suite.log'.

As expected, the problem is indeed in Ghostscript, which is missing one
its own initialization files (something like a configuration file in
data analysis).

This has probably happened during the update of your dependencies as you
described earlier. Can you uninstalling Ghostscript and then
re-installing it again? Afterwards, re-run 'make check' to see if the
error remains or not.

Hopefully an un-install and a clean install will replace all the missing
files and will fix this problem. If that doesn't work, try searching
this error message in your particular environment to see what other
people have reported on the internet.

Ultimately, Ghostscript is not used as a library in Gnuastro,
ConvertType just calls the Ghostscript executable ('gs'), with the
command that is shown at the end of the error message. So you can safely
run 'sudo make install' in Gnuastro. Afterwards, when you uninstall and
reinstall Ghostscript (or do any other changes to it based on other
checks), you can just run

astconvertt img.fits -oimg.pdf

And see if it works or not. It would be good to report the solution in
the bug-gnuastro@gnu.org mailing list so others also find your solution
in the future ;-).

Let us know how it goes,


    GNU Astronomy Utilities 0.19: tests/test-suite.log

# TOTAL: 76
# PASS:  75
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: convertt/fitstopdf.sh

GPL Ghostscript 9.55.0: Can't find initialization file gs_init.ps.
astconvertt: the Ghostscript command (printed after this message) to
convert the EPS file to PDF was not successful! The EPS file
('crop_section.pdf.ps') is left if you want to convert it through any
other means (for example the 'epspdf' program). The Ghostscript command
was: gs -q -o crop_section.pdf -sDEVICE=pdfwrite -dDEVICEWIDTHPOINTS=285
-dDEVICEHEIGHTPOINTS=137 -dPDFFitPage crop_section.pdf.ps
FAIL convertt/fitstopdf.sh (exit status: 1)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]